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1 Getting Started

Curve Fitting Toolbox Product Description

Fit curves and surfaces to data using regression, interpolation, and
smoothing

Curve Fitting Toolbox™ provides an app and functions for fitting curves and
surfaces to data. The toolbox lets you perform exploratory data analysis,
preprocess and post-process data, compare candidate models, and remove
outliers. You can conduct regression analysis using the library of linear and
nonlinear models provided or specify your own custom equations. The library
provides optimized solver parameters and starting conditions to improve

the quality of your fits. The toolbox also supports nonparametric modeling
techniques, such as splines, interpolation, and smoothing.

After creating a fit, you can apply a variety of post-processing methods for
plotting, interpolation, and extrapolation; estimating confidence intervals;
and calculating integrals and derivatives.

Key Features

e Curve Fitting app for curve and surface fitting
¢ Linear and nonlinear regression with custom equations

e Library of regression models with optimized starting points and solver
parameters

¢ Interpolation methods, including B-splines, thin plate splines, and
tensor-product splines

® Smoothing techniques, including smoothing splines, localized regression,
Savitzky-Golay filters, and moving averages

® Preprocessing routines, including outlier removal and sectioning, scaling,
and weighting data

® Post-processing routines, including interpolation, extrapolation, confidence
intervals, integrals and derivatives
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Curve Fitting Tools

Curve Fitting Tools

Curve Fitting Toolbox software allows you to work in two different
environments:

® An interactive environment, with the Curve Fitting app and the Spline Tool

® A programmatic environment that allows you to write object-oriented
MATLAB® code using curve and surface fitting methods

To open the Curve Fitting app or Spline Tool, enter one of the following:

e cftool

® splinetool

To list the Curve Fitting Toolbox functions for use in MATLAB programming,
type

help curvefit

The code for any function can be opened in the MATLAB Editor by typing

edit function_name

Brief, command line help for any function is available by typing

help function_name

Complete documentation for any function is available by typing

doc function_name

You can change the way any toolbox function works by copying and renaming
its file, examining your copy in the editor, and then modifying it.

You can also extend the toolbox by adding your own files, or by using your

code in combination with functions from other toolboxes, such as Statistics
Toolbox™ or Optimization Toolbox™ software.

1-3
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Curve Fitting

Interactive Curve Fitting
To interactively fit a curve, follow the steps in this simple example:

1 Load some data at the MATLAB command line.

load hahnt

2 Open the Curve Fitting app. Enter:

cftool

3 In the Curve Fitting app, select X Data and Y Data.
Curve Fitting app creates a default interpolation fit to the data.

4 Choose a different model type using the fit category drop-down list, e.g.,
select Polynomial.

5 Try different fit options for your chosen model type.
6 Select File > Generate Code.

Curve Fitting app creates a file in the Editor containing MATLAB code to
recreate all fits and plots in your interactive session.

For more information about fitting curves in the Curve Fitting app, see
“Interactive Curve and Surface Fitting” on page 2-2.

For details and examples of specific model types and fit analysis, see the
following sections:

1 “Linear and Nonlinear Regression”
2 “Interpolation”
3 “Smoothing”

4 “Fit Postprocessing”



Curve Fitting

Programmatic Curve Fitting

To programmatically fit a curve, follow the steps in this simple example:

1 Load some data.

load hahni

Create a fit using the fit function, specifying the variables and a model
type (in this case rat23 is the model type).

f = fit( temp, thermex, 'rat23' )

Plot your fit and the data.

plot( f, temp, thermex )
f( 600 )

See these sections:
1 “Curve and Surface Fitting” on page 3-2
2 “Curve and Surface Fitting Objects and Methods” on page 3-13

For details and examples of specific model types and fit analysis, see the
following sections:

1 “Linear and Nonlinear Regression”
2 “Interpolation”
3 “Smoothing”

4 “Fit Postprocessing”
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Surface Fitting

Interactive Surface Fitting
To interactively fit a surface, follow the steps in this simple example:

1 Load some data at the MATLAB command line.

load franke

2 Open the Curve Fitting app. Enter:

cftool

3 In the Curve Fitting app, select X Data, Y Data and Z Data.
Curve Fitting app creates a default interpolation fit to the data.

4 Choose a different model type using the fit category drop-down list, e.g.,
select Polynomial.

5 Try different fit options for your chosen model type.
6 Select File > Generate Code.

Curve Fitting app creates a file in the Editor containing MATLAB code to
recreate all fits and plots in your interactive session.

For more information about fitting surfaces in the Curve Fitting app, see
“Interactive Curve and Surface Fitting” on page 2-2.

For details and examples of specific model types and fit analysis, see the
following sections:

1 “Linear and Nonlinear Regression”
2 “Interpolation”
3 “Smoothing”

4 “Fit Postprocessing”



Surface Fitting

Programmatic Surface Fitting

To programmatically fit a surface, follow the steps in this simple example:

1 Load some data.

load franke

2 Create a fit using the fit function, specifying the variables and a model
type (in this case poly23 is the model type).

f = fit( [x, y], z, 'poly23' )
3 Plot your fit and the data.
plot(f, [x,y], z)
To programmatically fit surfaces, see the following topics:
1 “Curve and Surface Fitting” on page 3-2
2 “Curve and Surface Fitting Objects and Methods” on page 3-13

For details and examples of specific model types and fit analysis, see the
following sections:

1 “Linear and Nonlinear Regression”
2 “Interpolation”
3 “Smoothing”

4 “Fit Postprocessing”
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In this section...

“About Splines in Curve Fitting Toolbox” on page 1-8
“Interactive Spline Fitting” on page 1-9

“Programmatic Spline Fitting” on page 1-9

About Splines in Curve Fitting Toolbox

You can work with splines in Curve Fitting Toolbox in several ways.
Using the Curve Fitting app or the fit function you can:

¢ Fit cubic spline interpolants to curves or surfaces

* Fit smoothing splines and shape-preserving cubic spline interpolants to
curves (but not surfaces)

¢ Fit thin-plate splines to surfaces (but not curves)

The toolbox also contains specific splines functions to allow greater control
over what you can create. For example, you can use the csapi function for
cubic spline interpolation. Why would you use csapi instead of the fit
function 'cubicinterp' option? You might require greater flexibility to work
with splines for the following reasons:

® You want to combine the results with other splines, e.g., by addition.

®* You want vector-valued splines. You can use csapi with scalars, vectors,
matrices, and ND-arrays. The fit function only allows scalar-valued
splines.

® You want other types of splines such as ppform, B-form, tensor-product,
rational, and stform thin-plate splines.

® You want to create splines without data.

® You want to specify breaks, optimize knot placement, and use specialized
functions for spline manipulation such as differentiation and integration.




Spline Fitting

If you require specialized spline functions, see the following sections for
interactive and programmatic spline fitting.

Interactive Spline Fitting
You can access all spline functions from the splinetool GUI.
See “Introducing Spline Fitting” on page 8-2.

Programmatic Spline Fitting

To programmatically fit splines, see “Construction” for descriptions of types
of splines and numerous examples.
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Interactive Fitting

e “Interactive Curve and Surface Fitting” on page 2-2

e “Data Selection” on page 2-10

e “Create Multiple Fits in Curve Fitting App” on page 2-14

¢ “Generating MATLAB Code and Exporting Fits” on page 2-21
¢ “Compare Fits in Curve Fitting App” on page 2-22

e “Surface Fitting to Franke Data” on page 2-36



2 Interactive Fitting

Interactive Curve and Surface Fitting

In this section...

“Introducing the Curve Fitting App” on page 2-2

“Fit a Curve” on page 2-2

“Fit a Surface” on page 2-4

“Model Types for Curves and Surfaces” on page 2-6
“Selecting Data to Fit in Curve Fitting App” on page 2-7

“Save and Reload Sessions” on page 2-8

Introducing the Curve Fitting App

You can fit curves and surfaces to data and view plots with the Curve Fitting
app.
e (Create, plot, and compare multiple fits.

¢ Use linear or nonlinear regression, interpolation, smoothing, and custom
equations.

® View goodness-of-fit statistics, display confidence intervals and residuals,
remove outliers and assess fits with validation data.

* Automatically generate code to fit and plot curves and surfaces, or export
fits to the workspace for further analysis.

Fit a Curve
1 Load some example data at the MATLAB command line:

load census

2 Open the Curve Fitting app by entering:

cftool

Alternatively, click Curve Fitting on the Apps tab.
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3 Select X data and Y data. For details, see “Selecting Data to Fit in Curve
Fitting App” on page 2-7.

Fit name: untitled fit 1

¥ data: cdate -
Y data: pop -
£ data: (none) -
Weights: | (none) -

The Curve Fitting app creates a default polynomial fit to the data.

4 Try different fit options. For example, change the polynomial Degree to
3 to fit a cubic polynomial.

Polynaomial L
Degree: | 3 -
Robust: | Off -

Center and scale
Fit Options...

5 Select a different model type from the fit category list, e.g., Smoothing
Spline. For information about models you can fit, see “Model Types for
Curves and Surfaces” on page 2-6.
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| Polynomial -

Gaussian *
Interpolant

Palynaomial

Power

Ratienal

| Sum of Sine

Weibull

1

6 Select File > Generate Code.

The Curve Fitting app creates a file in the Editor containing MATLAB code
to recreate all fits and plots in your interactive session.

Tip For a detailed workflow example, see “Compare Fits in Curve Fitting
App” on page 2-22.

To create multiple fits and compare them, see “Create Multiple Fits in Curve
Fitting App” on page 2-14.

Fit a Surface
1 Load some example data at the MATLAB command line:

load franke

2 Open the Curve Fitting app:

cftool

3 Select X data, Y data and Z data. For more information, see “Selecting
Data to Fit in Curve Fitting App” on page 2-7.
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Fit name: |untitled fit1

A data: :x v:
¥ data: :],-' v:
Z data: :z v:
Weights: :I[nune:l v:

The Curve Fitting app creates a default interpolation fit to the data.
4 Select a different model type from the fit category list, e.g., Polynomial.

For information about models you can fit, see “Model Types for Curves
and Surfaces” on page 2-6.

| Interpolant -

Interpolant

Custom Equation
Lowess

5 Try different fit options for your chosen model type.
6 Select File > Generate Code.

The Curve Fitting app creates a file in the Editor containing MATLAB code
to recreate all fits and plots in your interactive session.

Tip For a detailed example, see “Surface Fitting to Franke Data” on page 2-36.

To create multiple fits and compare them, see “Create Multiple Fits in Curve
Fitting App” on page 2-14.
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Model Types for Curves and Surfaces

Based on your selected data, the fit category list shows either curve or
surface fit categories. The following table describes the options for curves
and surfaces.

Fit Category Curves Surfaces

Regression Models

Polynomial Yes (up to degree 9) Yes (up to degree 5)

Exponential Yes

Fourier Yes

Gaussian Yes

Power Yes

Rational Yes

Sum of Sine Yes

Weibull Yes

Interpolation

Interpolant Yes Yes
Methods: Methods:
Nearest neighbor Nearest neighbor
Linear Linear
Cubic Cubic
Shape-preserving Biharmonic (v4)
(PCHIP) Thin-plate spline

Smoothing

Smoothing Spline Yes

Lowess Yes

Custom

Custom Equation Yes Yes

Linear Fitting Yes

For information about these fit types, see:
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e “Linear and Nonlinear Regression”
® “Custom Models” on page 5-2
® “Interpolation”

® “Smoothing”

Selecting Data to Fit in Curve Fitting App
To select data to fit, use the drop-down lists in the Curve Fitting app to select

variables in your MATLAB workspace.
e To fit curves:

= Select X data and Y data.

= Select only Y data to plot Y against index (x=1:1ength( y )).
e To fit surfaces, select X data, Y data and Z data.

You can use the Curve Fitting app drop-down lists to select any numeric
variables (with more than one element) in your MATLAB workspace.

Similarly, you can select any numeric data in your workspace to use as
Weights.

Fit name: | untitled fit 1

¥ data: cdate -
Y data: pop b
£ data: (none) -
Weights: | (none) -

For curves, X, Y, and Weights must be matrices with the same number of
elements.
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For surfaces, X, Y, and Z must be either:

e Matrices with the same number of elements

¢ Data in the form of a table
For surfaces, weights must have the same number of elements as Z.

For more information see “Selecting Compatible Size Surface Data” on page
2-11.

When you select variables, the Curve Fitting app immediately creates a curve
or surface fit with the default settings. If you want to avoid time-consuming
refitting for large data sets, you can turn off Auto fit by clearing the check
box.

Note The Curve Fitting app uses a snapshot of the data you select.
Subsequent workspace changes to the data have no effect on your fits. To
update your fit data from the workspace, first change the variable selection,
and then reselect the variable with the drop-down controls.

If there are problems with the data you select, you see messages in the
Results pane. For example, the Curve Fitting app ignores Infs, NaNs, and
imaginary components of complex numbers in the data, and you see messages
in the Results pane in these cases.

If you see warnings about reshaping your data or incompatible sizes, read
“Selecting Compatible Size Surface Data” on page 2-11 and “Troubleshooting
Data Problems” on page 2-13 for information.

Save and Reload Sessions

® “Overview” on page 2-9
* “Saving Sessions” on page 2-9
¢ “Reloading Sessions” on page 2-9

¢ “Removing Sessions” on page 2-9
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Overview

You can save and reload sessions for easy access to multiple fits. The session
file contains all the fits and variables in your session and remembers your
layout.

Saving Sessions

To save your session, first select File > Save Session to open your file
browser. Next, select a name and location for your session file (with file
extension .sfit).

After you save your session once, you can use File > Save MySessionName to
overwrite that session for subsequent saves.

To save the current session under a different name, select File > Save
Session As .

Reloading Sessions

Use File > Load Session to open a file browser where you can select a saved
curve fitting session file to load.

Removing Sessions

Use File > Clear Session to remove all fits from the current Curve Fitting
app session.
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Data Selection

In this section...

“Selecting Data to Fit in Curve Fitting App” on page 2-10
“Selecting Compatible Size Surface Data” on page 2-11

“Troubleshooting Data Problems” on page 2-13

Selecting Data to Fit in Curve Fitting App

To select data to fit, use the drop-down lists in the Curve Fitting app to select
variables in your MATLAB workspace.

® To fit curves:

= Select X data and Y data.

= Select only Y data to plot Y against index (x=1:1ength( y )).
e To fit surfaces, select X data, Y data and Z data.

You can use the Curve Fitting app drop-down lists to select any numeric
variables (with more than one element) in your MATLAB workspace.

Similarly, you can select any numeric data in your workspace to use as
Weights.

Fit name: | untitled fit 1

X data: cdate -
Y data: pop -
£ data: (none) -
Weights: | (none) -

For curves, X, Y, and Weights must be matrices with the same number of
elements.
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For surfaces, X, Y, and Z must be either:

e Matrices with the same number of elements

¢ Data in the form of a table
For surfaces, weights must have the same number of elements as Z.

For more information see “Selecting Compatible Size Surface Data” on page
2-11.

When you select variables, the Curve Fitting app immediately creates a curve
or surface fit with the default settings. If you want to avoid time-consuming
refitting for large data sets, you can turn off Auto fit by clearing the check
box.

Note The Curve Fitting app uses a snapshot of the data you select.
Subsequent workspace changes to the data have no effect on your fits. To
update your fit data from the workspace, first change the variable selection,
and then reselect the variable with the drop-down controls.

Selecting Compatible Size Surface Data

For surface data, in Curve Fitting app you can select either “Matrices of the
Same Size” on page 2-11 or “Table Data” on page 2-11.

Matrices of the Same Size

Curve Fitting app expects inputs to be the same size. If the sizes are different
but the number of elements are the same, then the tool reshapes the inputs
to create a fit and displays a warning in the Results pane. The warning
indicates a possible problem with your selected data.

Table Data

Table data means that X and Y represent the row and column headers of
a table (sometimes called breakpoints) and the values in the table are the
values of the Z output.
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Sizes are compatible if:

e X is a vector of length n.

® Y is a vector of length m.

e 7 is a 2D matrix of size [m,n].

The following table shows an example of data in the form of a table with n

=4 andm = 3.

x(1) x(2) x(3) x(4)
y(1) z(1,1) z(1,2) z(1,3) z(1,4)
y(2) z(2,1) z(2,2) z(2,3) z(2,4)
y(3) z(3,1) z(3,2) z(3,3) z(3,4)

Like the surf function, the Curve Fitting app expects inputs where length (X)
= n, length(Y) = mand size(Z) = [m,n]. If the size of Zis [n,m], the tool
creates a fit but first transposes Z and warns about transforming your data.
You see a warning in the Results pane like the following example:

Using X Input for rows and Y Input for columns
to match Z Output matrix.

For suitable example table data, run the following code:

x = linspace( 0, 1, 7 );
y = linspace( 0, 1, 9 )."';
z = bsxfun( @franke, x, y );

For surface fitting at the command line with the fit function, use the
prepareSurfaceData function if your data is in table form.

Weights

If you specify surface Weights, assign an input the same size as Z. If the
sizes are different but the number of elements is the same, Curve Fitting app
reshapes the weights and displays a warning.
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Troubleshooting Data Problems

If there are problems with the data you select, you see messages in the
Results pane. For example, the Curve Fitting app ignores Infs, NaNs, and
imaginary components of complex numbers in the data, and you see messages
in the Results pane in these cases.

If you see warnings about reshaping your data or incompatible sizes, read
“Selecting Compatible Size Surface Data” on page 2-11 for information.

If you see the following warning: Duplicate x-y data points detected:
using average of the z values., this means that there are two or more
data points where the input values (x, y) are the same or very close together.
The default interpolant fit type needs to calculate a unique value at that
point. You do not need do anything to fix the problem, this warning is just for
your information. The Curve Fitting app automatically takes the average z
value of any group of points with the same x-y values.

Other problems with your selected data can produce the following error:

Error computing Delaunay triangulation. Please try again with
different data.

Some arrangements of data make it impossible for Curve Fitting app to
compute a Delaunay triangulation. Three out of the four surface interpolation
methods (linear, cubic, and nearest) require a Delaunay triangulation of the
data. An example of data that can cause this error is a case where all the
data lies on a straight line in x-y. In this case, Curve Fitting app cannot fit a
surface to the data. You need to provide more data in order to fit a surface.

Note Data selection is disabled if you are in debug mode. Exit debug mode to
change data selections.
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Create Multiple Fits in Curve Fitting App

In this section...

“Refining Your Fit” on page 2-14

“Creating Multiple Fits” on page 2-14

“Duplicating a Fit” on page 2-15

“Deleting a Fit” on page 2-15

“Displaying Multiple Fits Simultaneously” on page 2-15

“Using the Statistics in the Table of Fits” on page 2-19

Refining Your Fit

After you create a single fit, you can refine your fit, using any of the following
optional steps:

¢ Change fit type and settings. Select GUI settings to use the Curve Fitting
app built-in fit types or create custom equations. For fit settings for each
model type, see “Linear and Nonlinear Regression”, “Interpolation”, and
“Smoothing”.

¢ Exclude data by removing outliers in the Curve Fitting app. See “Remove
Outliers” on page 7-10.

® Select weights. See “Data Selection” on page 2-10.
o Select validation data. See “Select Validation Data” on page 7-15

¢ (Create multiple fits and you can compare different fit types and settings
side by side in the Curve Fitting app. See “Creating Multiple Fits” on page
2-14.

Creating Multiple Fits

After you create a single fit, it can be useful to create multiple fits to compare.
When you create multiple fits you can compare different fit types and settings
side-by-side in the Curve Fitting app.

After creating a fit, you can add an additional fit using any of these methods:
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¢ (Click the New Fit button next to your fit figure tabs in the Document Bar.
¢ Right-click the Document Bar and select New Fit.

* Select Fit > New Fit.

Each additional fit appears as a new tab in the Curve Fitting app and a new

row in the Table of Fits. See “Create Multiple Fits in Curve Fitting App” on
page 2-14 for information about displaying and analyzing multiple fits.

Optionally, after you create an additional fit, you can copy your data selections
from a previous fit by selecting Fit > Use Data From > Other Fit Name.
This copies your selections for x, y, and z from the previous fit, and any
selected validation data. No fit options are changed.

Use sessions to save and reload your fits. See “Save and Reload Sessions”
on page 2-8.

Duplicating a Fit
To create a copy of the current fit tab, select Fit > Duplicate "Current Fit
Name". You also can right-click a fit in the Table of Fits and select Duplicate

Each additional fit appears as a new tab in the Curve Fitting app.

Deleting a Fit

Delete a fit from your session using one of these methods:

e Select the fit tab display and select Fit > Delete Current Fit Name.
e Select the fit in the Table of Fits and press Delete.
¢ Right-click the fit in the table and select Delete Current Fit Name.

Displaying Multiple Fits Simultaneously

When you have created multiple fits you can compare different fit types
and settings side by side in the Curve Fitting app. You can view plots
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simultaneously and you can examine the goodness-of-fit statistics to compare
your fits. This section describes how to compare multiple fits.

To compare plots and see multiple fits simultaneously, use the layout controls
at the top right of the Curve Fitting app. Alternatively, you can click Window
on the menu bar to select the number and position of tiles you want to display.
A fit figure displays the fit settings, results pane and plots for a single fit. The
following example shows two fit figures displayed side by side. You can see
multiple fits in the session listed in the Table of Fits.

4\ Curve Fitting Tool - exampleinteractivecurvefits EI@
File Fit View Tools Desktop Window Help ]
R0 E - B % B@a & O
poly2 = poly3 = |exp =x U
exp poly3 02 x
Fit name: |exp Exponential Fit name: | poly3 Polynomial
Adata: | cdate | Number of terms: | 1 Hdata: | cdate = Degree: | 3
Y data: pop v: Equation: e Y data: pop v: Robust | Off
Z data: (none) v: [7] Center and scale Z data: (none) v: [7] Center and scale
Weights: (none) ': Weights: (none) ':
Results <* Results [T 1 I L ¥
200+ exp 1 o 200+ poly3
General model o vs. cdate i Linear mode— o vs. cdate
9 === | & 100 = P 2 =l || Qg Ly 3
Coefficients {wi where 3 .
a= 4851 _ Coefficients ou”
b= 0.01 ) eesee®” | | ] pl= 0 reasss®” | | |
1800 1850 1900 1950 2000 p2= 1800 1850 1900 1950 2000
Goodness of fit] p3=
SSE: 1804 cdate pd= |- cdate
R-square: 0.9 F = 1 r = =
Adjusted R-sq 10+ aa® - 11 Goodness o 4 L - b
RMSE: 9,985 e exp - residuals CSF: 140.8 2r ot e poly3 - residuals
2 0 - L R-square: a 0 e* eyrare— 11
8_ “ L Adjusted F 8. -2 ce . .
10 904 le0” | RMSE: 2.9 41
- | ! ! . — 6 I [ LJ ]
g 1800 1850 1900 1950 2000 _ S 1800 1850 1900 1950 2000
4 » 4 3
cdate cdate
Table of Fits g [0 &
Fit na... « Data Fittype  SSE R-square DFE Adj R-sq RMSE #Coeff  Validati.. Validati.. Validati...
& exp pop vs. Co. |expl 1.8942e+... 0.9847 19 0.9839 9.9847 2 =
& poly2  |pop vs. c... [poly2 754368  |0.9994 18 0.9993 2.0472 E] |__
[ poly?  |pop vs. c.. [poly3 1407687 |0.0988 17 0.9986 2.0682 4 |:=
[ polyt  [pop vs. c... |polyd 1459689 |0.0988 16 0.9985 3.0204 5 i
@ polyS  |pop vs. .. [polyS 1441661 |0.9988 15 0.9984 31002 6 2
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You can close fit figures displays (with the Close button, Fit menu, or context
menu), but they remain in your session. The Table of Fits displays all your

fits (open and closed). Double-click a fit in the Table of Fits to open (or focus
if already open) the fit figure. To remove a fit, see “Deleting a Fit” on page 2-15

Tip If you want more space to view and compare plots, as shown next, use
the View menu to hide or show the Fit Settings, Fit Results, or Table of
Fits panes.
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4\ Curve Fitting Tool - exampleinteractivecurvefits EI@

Eile Fit View Tools Desktop Window Help N
-+:\- ._:\- {ﬂ-? \'Jl_“_ - @ l%{‘s EHE & 0O
poly2 o x| T

exp O 2 X | poly3
250f — ' I o 250 | e
exp poly3
e popvs. cdate e popvs. cdate
200 ¢ : 7 200 ¢ : 7
./ ./
150 t/ 150+ /‘/
o ./ a .
[=] ™ =] [
a a J
L) [ ]
100 + . 1 100 ¢ o
- ’./
50+ .’. | 50 L ’./.
/ o*
0+ see® «* | 0 :—.-.-l-."'. |
1800 1850 1900 1950 2000 1800 1850 1900 1950 2000
cdate 3 cdate
- 1 4 P
10 & 2xp - residuals « poly3 - residuals

| T‘ I' ' ol 11 TTI.

0} b l ' l .
(= (=8 ™
[=] - l [=] ®
[=% o 5|
.5 F
]
-
10+ e -4
e
-15} - -6 g
- L]
1800 1850 1900 1950 2000 1800 1850 1900 1950 2000
cdate cdate

You can dock and undock individual fits and navigate between them using
the standard MATLAB Desktop and Window menus in the Curve Fitting
app. For more information, see “Optimize Desktop Layout for Limited Screen
Space” in the MATLAB Desktop Tools and Development Environment
documentation.
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Using the Statistics in the Table of Fits

The Table of Fits list pane shows all fits in the current session.

Table af Fits

Fit name  Data Fit type S5E R-square  DFE AdjR-sq  RMSE # Coeff
M poly®  |popvs. cd...|polyb 1069276 (09991 14 0.9988 2.7636 7

M poly5  |pop vs. cd...|poly5 1441661 (09988 15 0.9984 31002 G

[ polyd pop vs. cd...|polyd 1459659 09988 16 0.9985 3.0204 5

M poly3  |popvs. cd...|poly3 149.7687  |0.0988 17 0.9985 29682 4

M poly2  |popvs. cd...|poly2 158.0293 09987 13 0.9985 29724 E

A exp pop vs. od..|expl 1.5942e+03 |0.9847 19 0.9839 99847 2

After using graphical methods to evaluate the goodness of fit, you can examine
the goodness-of-fit statistics shown in the table to compare your fits. The
goodness-of-fit statistics help you determine how well the model fits the data.
Click the table column headers to sort by statistics, name, fit type, and so on.

The following guidelines help you use the statistics to determine the best fit:

SSE is the sum of squares due to error of the fit. A value closer to zero

indicates a fit that is more useful for prediction.

R-square is the square of the correlation between the response values and
the predicted response values. A value closer to 1 indicates that a greater

proportion of variance is accounted for by the model.

DFE is the degree of freedom in the error.

Adj R-sq is the degrees of freedom adjusted R-square. A value closer to 1

indicates a better fit.

RMSE is the root mean squared error or standard error. A value closer to 0

indicates a fit that is more useful for prediction.

# Coeff is the number of coefficients in the model. When you have several
fits with similar goodness-of-fit statistics, look for the smallest number of

coefficients to help decide which fit is best. You must trade off the number
of coefficients against the goodness of fit indicated by the statistics to avoid

overfitting.
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For a more detailed explanation of the Curve Fitting Toolbox statistics, see
“Goodness-of-Fit Statistics” on page 7-58.

To compare the statistics for different fits and decide which fit is the best
tradeoff between over- and under-fitting, use a similar process to that

described in “Compare Fits in Curve Fitting App” on page 2-22.

Related ® “Compare Fits in Curve Fitting App” on page 2-22
Examples ¢ “Compare Fits Programmatically” on page 7-42
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Generating MATLAB Code and Exporting Fits

Interactive Code Generation and Programmatic
Fitting

Curve Fitting app makes it easy to plot and analyze fits at the command line.
You can export individual fits to the workspace for further analysis, or you
can generate MATLAB code to recreate all fits and plots in your session. By
generating code you can use your interactive curve fitting session to quickly
assemble code for curve and surface fits and plots into useful programs.

1 Select File > Generate Code.

The Curve Fitting app generates code from your session and displays the
file in the MATLAB Editor. The file includes all fits and plots in your
current session. The file captures the following information:

Names of fits and their variables

Fit settings and options

Plots

® Curve or surface fitting objects and methods used to create the fits:
= A cell-array of cfit or sfit objects representing the fits

= A structure array with goodness-of fit information.

2 Save the file.

For more information on working with your generated code, exporting fits to
the workspace, and recreating your fits and plots at the command line, see:

® “Generating Code from the Curve Fitting App” on page 7-16
e “Exporting a Fit to the Workspace” on page 7-17
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Compare Fits in Curve Fitting App

2-22

In this section...

“Interactive Curve Fitting Workflow” on page 2-22
“Loading Data and Creating Fits” on page 2-22
“Determining the Best Fit” on page 2-26

“Analyzing Your Best Fit in the Workspace” on page 2-32

“Saving Your Work” on page 2-34

Interactive Curve Fitting Workflow
The next topics fit some census data using polynomial equations up to the

sixth degree, and a single-term exponential equation. The steps demonstrate
how to:
¢ Load data and explore various fits using different library models.
e Search for the best fit by:
= Comparing graphical fit results

= Comparing numerical fit results including the fitted coefficients and
goodness-of-fit statistics

® Export your best fit results to the MATLAB workspace to analyze the
model at the command line.

¢ Save the session and generate MATLAB code for all fits and plots.

Loading Data and Creating Fits
You must load the data variables into the MATLAB workspace before you can

fit data using the Curve Fitting app. For this example, the data is stored in
the MATLAB file census.mat.
1 Load the data:

load census

The workspace contains two new variables:
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® cdate is a column vector containing the years 1790 to 1990 in 10-year
increments.

® pop is a column vector with the U.S. population figures that correspond
to the years in cdate.

Open the Curve Fitting app:

cftool

Select the variable names cdate and pop from the X data and Y data lists.

The Curve Fitting app creates and plots a default fit to X input (or predictor
data) and Y output (or response data). The default fit is a linear polynomial
fit type. Observe the fit settings display Polynomial, of Degree 1.

Change the fit to a second degree polynomial by selecting 2 from the
Degree list.

The Curve Fitting app plots the new fit. The Curve Fitting app calculates a
new fit when you change fit settings because Auto fit is selected by default.
If refitting is time consuming, e.g., for large data sets, you can turn off
Auto fit by clearing the check box.

The Curve Fitting app displays results of fitting the census data with a
quadratic polynomial in the Results pane, where you can view the library
model, fitted coefficients, and goodness-of-fit statistics.

Change the Fit name to poly2.
Display the residuals by selecting View > Residuals Plot.

The residuals indicate that a better fit might be possible. Therefore,
continue exploring various fits to the census data set.
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4\ Curve Fitting Tool
File Fit View Tools Desktop Window Help ] | A X
FEE & TR =Rul=R=lin]
[(bobz ] £
Fit name: | poly2 Paolynomial - Auto fit
X data: cdate ~ Degree: 2 ': Fit
Y data: pop 'j Robust: Off V: Stop
Z data: {(none) ': [] Center and scale
Weights: (none) b
Results - . | I I I I I i I . -"" .

200 -

poly2 1
Linear model Poly2: & popvs. cdate
filx) = p1™%2 +p2%% +p3 :

Coefficients (with 95% confidence bound 100 - 1
pl= 0.006541 (0.006124, 0.0065
p2 = -23.51 {-25.09, -21.33) 0
| = L L 1 1 i 1

p3 = 2.113e+004 (1.964e+004, 2. - : - 1 1 =
1780 1800 1820 1840 1860 1880 1900 1920 1940 1960 1980 2000
Goodness of fit:
SSE: 159 cdate

pop

R-square: 0.9987 4 T T T T . T T L4 ]
Adjusted R-square: 0.9986 2l T o 1.4
RMSE: 2,972 0 L e e . e . 9% | [——e poh2-rmesiduals
® * 5 =
.
) ]
_4 = -4
|
-8 I . ) \ i s
1780 1800 1820 1840 1860 1880 1900 1920 1940 1960 1980 2000
4 I r
cdate
Table of Fits O x
Fit na.. = Data Fit type S5E R-square  DFE AdjR-sg  RMSE # Coeff Validatio... Validatio... Validatio...
@ poly?  |pop vs. cd...|poly2 [159.0203  |0.9987 13 09986 2.9724 3

7 Add new fits to try the other library equations.

a Right-click the fit in the Table of Fits and select Duplicate “poly2” (or
use the Fit menu).
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Tip For fits of a given type (for example, polynomials), use Duplicate
“fitname” instead of a new fit because copying a fit requires fewer steps.
The duplicated fit contains the same data selections and fit settings.

b Change the polynomial Degree to 3 and rename the fit poly3.

¢ When you fit higher degree polynomaials, the Results pane displays
this warning:

Equation is badly conditioned. Remove repeated data points
or try centering and scaling.

Normalize the data by selecting the Center and scale check box.

d Repeat steps a and b to add polynomial fits up to the sixth degree, and
then add an exponential fit.

e For each new fit, look at the Results pane information, and the residuals
plot in the Curve Fitting app.

The residuals from a good fit should look random with no apparent
pattern. A pattern, such as a tendency for consecutive residuals to have
the same sign, can be an indication that a better model exists.

About Scaling

The warning about scaling arises because the fitting procedure uses the cdate
values as the basis for a matrix with very large values. The spread of the
cdate values results in a scaling problem. To address this problem, you can
normalize the cdate data. Normalization scales the predictor data to improve
the accuracy of the subsequent numeric computations. A way to normalize
cdate is to center it at zero mean and scale it to unit standard deviation.
The equivalent code is:

(cdate - mean(cdate))./std(cdate)
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Note Because the predictor data changes after normalizing, the values of the
fitted coefficients also change when compared to the original data. However,
the functional form of the data and the resulting goodness-of-fit statistics

do not change. Additionally, the data is displayed in the Curve Fitting app
plots using the original scale.

Determining the Best Fit

To determine the best fit, you should examine both the graphical and
numerical fit results.

Examine the Graphical Fit Results

1 Determine the best fit by examining the graphs of the fits and residuals. To
view plots for each fit in turn, double-click the fit in the Table of Fits. The
graphical fit results indicate that:

The fits and residuals for the polynomial equations are all similar,
making it difficult to choose the best one.

The fit and residuals for the single-term exponential equation indicate it
is a poor fit overall. Therefore, it is a poor choice and you can remove the
exponential fit from the candidates for best fit.

2 Examine the behavior of the fits up to the year 2050. The goal of fitting the
census data is to extrapolate the best fit to predict future population values.

Double-click the sixth-degree polynomial fit in the Table of Fits to view
the plots for this fit.

Change the axes limits of the plots by selecting Tools > Axes Limits.

Alter the X (cdate) Maximum to 2050, and increase the Main Y (pop)
Maximum to 400, and press Enter.

Examine the fit plot. The behavior of the sixth-degree polynomial fit
beyond the data range makes it a poor choice for extrapolation and you
can reject this fit.
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Evaluate the Numerical Fit Results

When you can no longer eliminate fits by examining them graphically, you
should examine the numerical fit results. The Curve Fitting app displays two

types of numerical fit results:

® Goodness-of-fit statistics

e Confidence bounds on the fitted coefficients

The goodness-of-fit statistics help you determine how well the curve fits the
data. The confidence bounds on the coefficients determine their accuracy.

Examine the numerical fit results:

1 For each fit, view the goodness-of-fit statistics in the Results pane.
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Table of Fits

Results

pl=
p2=
p3 =
pd =

Linear model Poly3:
fix) =p1™x~3 +p2*"2 +p3™ +p4
where x is normalized by mean 1890 and std 62.05
Coeffidents (with 95% confidence bounds):
0.921 (-0.9743, 2.818)

25,18 {23.57, 26.79)
73.86 (70.33, 77.39)
61.74 (59.69, 63.8)

Goodness of fit:
55E: 149.8
R-sguare: 0.9985
Adjusted R-square: 0.9986
RMSE: 2.968

2 Compare all fits simultaneously in the Table of Fits. Click the column

headings to sort by statistics results.

Fit name  Data Fit type S5E R-square  DFE AdjR-sq  RMSE # Coeff
M polyt  |pop vs. cd...|poly6 1069276  |0.9991 14 0.9988 2.7636 7
M polyS  |pop vs. cd...|polyS 1441661  |0.99383 15 0.9984 31002 15
[ polyd  |pop vs. cd...|polyd 1459689  |0.9933 16 0.9985 3.0204 5
M poly3  |pop vs. cd...|poly3 149.7687  |0.9988 17 0.9986 29682 4
M poly2  |pop vs. cd...|poly2 1590293  |0.9987 18 0.9986 29724 3
M exp pop vs. cd..|expl 1.8942e+03 |0.9847 19 0.9839 9.9847 2

3 Examine the sum of squares due to error (SSE) and the adjusted
R-square statistics to help determine the best fit. The SSE statistic is the
least-squares error of the fit, with a value closer to zero indicating a better
fit. The adjusted R-square statistic is generally the best indicator of the fit
quality when you add additional coefficients to your model.

The largest SSE for exp1 indicates it is a poor fit, which you already
determined by examining the fit and residuals. The lowest SSE value is
associated with poly6. However, the behavior of this fit beyond the data
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range makes it a poor choice for extrapolation, so you already rejected this
fit by examining the plots with new axis limits.

The next best SSE value is associated with the fifth-degree polynomial fit,

poly5, suggesting it might be the best fit. However, the SSE and adjusted

R-square values for the remaining polynomial fits are all very close to each
other. Which one should you choose?

4 Resolve the best fit issue by examining the confidence bounds for the
remaining fits in the Results pane. Double-click a fit in the Table of Fits
to open (or focus if already open) the fit figure and view the Results pane. A
fit figure displays the fit settings, results pane and plots for a single fit.

Display the fifth-degree polynomial and the poly2 fit figures side by side.
Examining results side by side can help you assess fits.

a To show two fit figures simultaneously, use the layout controls at the top
right of the Curve Fitting app or select Window > Left/Right Tile or
Top/Bottom Tile.

b To change the displayed fits, click to select a fit figure and then
double-click the fit to display in the Table of Fits.

¢ Compare the coefficients and bounds (p1, p2, and so on) in the Results
pane for both fits, poly5 and poly2. The toolbox calculates 95%
confidence bounds on coefficients. The confidence bounds on the
coefficients determine their accuracy. Check the equations in the
Results pane (f(x)=p1*x+p2*x...) to see the model terms for each
coefficient. Note that p2 refers to the p2*x term in Poly2 and the p2*x*~4
term in Poly5. Do not compare normalized coefficients directly with
non-normalized coefficients.

Tip Use the View menu to hide the Fit Settings or Table of Fits if
you want more space to view and compare plots and results, as shown
next. You can also hide the Results pane to show only plots.
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4\ Curve Fitting Tool EI@

Eile Fit View Tools Desktop Window Help k]

-llwi"?*ﬂ : |[EE) % B OESs O

| poly2 pely3 polyd | poly5 l polyd  ® | exp ¥ hﬂ
poly>
| T T T T T T T T T T [
Result . e
esults . N 200 - bolys

Linear model Poly5: [=] . vs. cdate

Fx) = P15 + P25 "4 433 | Q100 - s el B
where x is normalized by mean 189 .__.__.-—-r"‘""'

Coeffidents (with 95% confidence bour () =—e—a—n—8—0— =
pl= 0.5877 (-2.305,3.48) |_ 1780 1800 1820 1840 1860 1880 190'0 1920 1940 1960 1930 2000
p2=  0.7047 (-L684, 3.094) |= cdate
p3 = -0.9193 {-10.19, 8.356)
pd=  23.47 (17.42, 29.53) 5 T T T i T T i T Ty 3
ps=  74.97 (58.37, 81.57) [ . !

B e poly5 - residuals
p6 = 62,23 (59.51, 64.95) 8- 0! « * L Y ° 5 * ‘ - s ® T T S —_—
= .
Goodness of fit:
SSE: 144.2 S , S ]
. Twl i 1780 1800 1820 1840 1860 1880 1900 1920 1940 1960 1980 2000
cdate
poly2 ) O a2 x
Results . I I | I | | I r ] I .'Il"r |
A poly2

Linear model Paly2: =
fix) = pl™"2 +p2®x +p3

Coefficents {with 95% confidence bour,

pl= 0.006541 {0.006124, 0.00¢

0: . : i E i i L 1 L
p2= -23.51 (-25.09, -21.93) 1780 1800 1820 1840 1860 1880 1900 1920 1940 1960 1980 2000
p3 = 2.113e+004 (1.964e+004, .

& popvs. cdate| |

= cdate
Goodness of fit: 4F T T T ' T T 1 T T T =
E?SEC:]ulasrge: 0.9987 a % T B B E—" T ° * T f_ e poly2 - residuals H
Adjusted R-square: 0.9936 8_ -2 I — T
RMSE: 2,972 -4 ]
] B+ ]
-8 I ® e
. - . k 1780 1300 1320 1840 1850 1880 1900 1920 1940 1960 1930 2000
cdate

The bounds cross zero on the p1, p2, and p3 coefficients for the
fifth-degree polynomial. This means you cannot be sure that these
coefficients differ from zero. If the higher order model terms may have
coefficients of zero, they are not helping with the fit, which suggests that
this model overfits the census data.
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Results

Linear model Poly5:

Coeffidents (with 95% confidence bounds):
pl= 0.5877 {-2.305, 3.48)
p2=  0.7047 (-1.584, 3.099)
p3= -0.9193 (-10.19, 8.356)
pd=  23.47 (17.42, 29.52)
pS=  74.97 (68.37, 81.57)
p6=  62.23 (59.51, 54.95)

Goodness of fits
55E: 144.2
R-sguare: 0.9988
Adjusted R-sguare: 0.9984
EMSE: 3.1

(i) = p1™"5 + p2=0"4 + p3="3 +pd="2 +p5*u +ph
where x is normalized by mean 1590 and std 62,05

However, the small confidence bounds do not cross zero on p1, p2, and
p3 for the quadratic fit, poly2 indicate that the fitted coefficients are

known fairly accurately.

Results

Linear model Poly2:
) =p1™"~2 +p2™x +p3
Coeffidents (with 95% confidence bounds):
pl= 0.006541 (0.006124, 0.0056953)
pZ= -23.51 (-25.08, -21.93)
p3 = 2,113e+004 (1.964e+004, 2.262e+004)

Goodness of fit:
S5E: 159
R-square: 0.9937
Adjusted R-square: 0.9936
RMSE: 2.972

Therefore, after examining both the graphical and numerical fit results,
you should select poly2 as the best fit to extrapolate the census data.
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Note The fitted coefficients associated with the constant, linear, and
quadratic terms are nearly identical for each normalized polynomial equation.
However, as the polynomial degree increases, the coefficient bounds
associated with the higher degree terms cross zero, which suggests overfitting.

Analyzing Your Best Fit in the Workspace

You can use Save to Workspace to export the selected fit and the associated
fit results to the MATLAB workspace. The fit is saved as a MATLAB object
and the associated fit results are saved as structures.

1 Right-click the poly2 fit in the Table of Fits and select Save “poly2” to
Workspace (or use the Fit menu).

Save Fit to MATLABE Workspace El@

[¥] Save fit to MATLAB object named: fittedmodel

I

@ Save goodness of fit to MATLAB struct named: goodness

[¥] Save fit output to MATLAB struct named: output

=

OK l Cancel ]

2 Click OK to save with the default names.
The fittedmodel is saved as a Curve Fitting Toolbox cfit object.

>> whos fittedmodel
Name Size Bytes Class

fittedmodel 1x1 822 cfit

Examine the fittedmodel cfit object to display the model, the fitted
coefficients, and the confidence bounds for the fitted coefficients:

fittedmodel
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fittedmodel =
Linear model Poly2:
fittedmodel(x) = p1*x"2 + p2*x + p3
Coefficients (with 95% confidence bounds):
p1 = 0.006541 (0.006124, 0.006958)
p2 = -23.51 (-25.09, -21.93)
p3 = 2.113e+004 (1.964e+004, 2.262e+004)

Examine the goodness structure to display goodness-of-fit results:
goodness
goodness =

sse: 159.0293
rsquare: 0.9987

dfe: 18
adjrsquare: 0.9986
rmse: 2.9724

Examine the output structure to display additional information associated
with the fit, such as the residuals:

output

output =
numobs: 21
numparam: 3
residuals: [21x1 double]
Jacobian: [21x3 double]
exitflag: 1
algorithm: 'QR factorization and solve'
iterations: 1

You can evaluate (interpolate or extrapolate), differentiate, or integrate a fit
over a specified data range with various postprocessing functions.

For example, to evaluate the fittedmodel at a vector of values to extrapolate
to the year 2050, enter:

y = fittedmodel(2000:10:2050)
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274.6221
301.8240
330.3341
360.1524
391.2790
423.7137

Plot the fit to the census data and the extrapolated fit values:

plot(fittedmodel, cdate, pop)

hold on

plot(fittedmodel, 2000:10:2050, y)
hold off

For more examples and instructions for interactive and command-line fit
analysis, and a list of all postprocessing functions, see “Fit Postprocessing”.

For an example reproducing this interactive census data analysis using the
command line, see “Polynomial Curve Fitting” on page 3-5.

Saving Your Work

The toolbox provides several options for saving your work. You can save
one or more fits and the associated fit results as variables to the MATLAB
workspace. You can then use this saved information for documentation
purposes, or to extend your data exploration and analysis. In addition to
saving your work to MATLAB workspace variables, you can:

® Save the current curve fitting session by selecting File > Save Session.
The session file contains all the fits and variables in your session and
remembers your layout. See “Save and Reload Sessions” on page 2-8.

® Generate MATLAB code to recreate all fits and plots in your session by
selecting File > Generate Code. The Curve Fitting app generates code
from your session and displays the file in the MATLAB Editor.

You can recreate your fits and plots by calling the file at the command
line with your original data as input arguments. You can also call the
file with new data, and automate the process of fitting multiple data sets.
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For more information, see “Generating Code from the Curve Fitting App”

on page 7-16.
Related e “Create Multiple Fits in Curve Fitting App” on page 2-14
Exqmples e “Evaluate a Curve Fit” on page 7-20
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Surface Fitting to Franke Data
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The Curve Fitting app provides some example data generated from Franke’s
bivariate test function. This data is suitable for trying various fit settings
in Curve Fitting app.

To load the example data and create, compare, and export surface fits, follow
these steps:

1 To load example data to use in the Curve Fitting app, enter load franke

at the MATLAB command line. The variables x, y, and z appear in your
workspace.

The example data is generated from Franke’s bivariate test function,
with added noise and scaling, to create suitable data for trying various
fit settings in Curve Fitting app. For details on the Franke function, see
the following paper:

Franke, R., Scattered Data Interpolation: Tests of Some Methods,
Mathematics of Computation 38 (1982), pp. 181-200.

To divide the data into fitting and validation data, enter the following
syntax:

Xv = x(200:293);
yv = y(200:293);
zv = z(200:293);
X = x(1:199);
y = y(1:199);
z = z(1:199);

To fit a surface using this example data:

a Open Curve Fitting app. Enter cftool, or select Curve Fitting on the
Apps tab.

b Select the variables x, y, and z interactively in the Curve Fitting app.



Surface Fitting to Franke Data

Fit name: Iunﬁtleu:l fit1
X input: (none) LI
g —
Z output: [V
¥
Weights: |yv
Z =
Results v
0 Select X input, ¥ input and Z output

Alternatively, you can specify the variables when you enter

cftool(x,y,z) to open Curve Fitting app (if necessary) and create a
default fit.

The Curve Fitting app plots the data points as you select variables. When
you select x, y, and z, the tool automatically creates a default surface fit.

The default fit is an interpolating surface that passes through the data
points.
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4\ Curve Fitting Tool

=lfe =]
File Fit View Tools Desktop Window Help N
o & @ QS 0E - |EHE) % HOEes O
n
untitled fit 1

Fit name: untitled fit 1 Interpolant

=) Auto fil
Adata: | x I Method: | Linear N Fit
Y data: ¥ = [¥] Center and scale Stop
Zdata: |z hd
Weights: | (none) -
Results

Linear interpolant: i
flx,v) = piecewise line
where x is normalized
and where y is normali = N

Coefficients:

p = coefficient structy

Goodness of fit:
S5E; 1.001e-030
R-square: 1 -
1 il 3

ol
Fit ... Data Fittype SSE R-squ.. DFE AdjR-.. RMSE  # Coeff Valida.. Valida.. Valida..
[ unti...|zvs. %,y [linearin...|1.0008e...|1 o [Nan [Mam 20z | | |

4 Try a Lowess fit type. Select the Lowess fit type from the drop-down list in
the Curve Fitting app.

Interpolant LI
Interpolant
Polynomial

Custom Equation

The Curve Fitting app creates a local smoothing regression fit.

5 Try altering the fit settings. Enter 10 in the Span edit box.
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By reducing the span from the default to 10% of the total number of data
points you produce a surface that follows the data more closely. The span
defines the neighboring data points the toolbox uses to determine each
smoothed value.

. . .
y s00 1000 1500 2000 2500 3000
K

6 Edit the Fit name to Smoothing regression.

7 If you divided your data into fitting and validation data in step 2, select
this validation data. Use the validation data to help you check that your
surface is a good model, by comparing it against some other data not used
for fitting.

a Select Fit > Specify Validation Data. The Specify Validation Data
dialog box opens.

b Select the validation variables in the drop-down lists for X input, Y
input, and Z output: xv, yv, and zv.

Review your selected validation data in the plots and the validation
statistics (SSE and RMSE) in the Results pane and the Table of Fits.
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: : : - [ Smoothing regression
1\ ___________ oo ) G ononssrammcies ® zuysowy
' IV WS, WY, Y

.................

y 0 “epp 1000 1500 2000 2500 3000
H

8 Create another fit to compare by making a copy of the current surface fit.
Either select Fit > Duplicate "Smoothing regression”, or right-click the
fit in the Table of Fits, and select Duplicate

The tool creates a new fit figure with the same fit settings, data, and
validation data. It also adds a new row to the table of fits at the bottom.

9 Change the fit type to Polynomial and edit the fit name to Polynomial.

Lowess LI
Interpolant

Polynomial

Custom Equation
Lowess

10 Change the Degrees of x and y to 3, to fit a cubic polynomial in both
dimensions.

11 Look at the scales on the x and y axes, and read the warning message
in the Results pane:

Equation is badly conditioned. Remove repeated data points
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or try centering and scaling.

Select the Center and scale check box to normalize and correct for the
large difference in scales in x and y.

Polynomial ;I
Degrees: x: |3 LI VE |3 LI
Robust: I off LI

Fit Options... |

Normalizing the surface fit removes the warning message from the Results

pane.

12 Look at the Results pane. You can view (and copy if desired):

® The model equation

e The values of the estimated coefficients

® The goodness-of-fit statistics

¢ The goodness of validation statistics

Linear model Poly33:

F(x,y)

Coefficients

p0o0
p10
po1

p20 =
p11 =

p02
p30

= p00 + p10*x + pO1*y + p20*x"2 + pli1*x*y...
+ p02*y

"2 + p30*x"3 + p21*x"2*y

+ p12*x*y~2 + p03*y"3

where x is normalized by mean 1977 and std 866.5

and where y is normalized by mean 0.4932 and std 0.29
(with 95% confidence bounds):

0.4359
-0.1375
-0.4274

0.0161
0.07158

-0.03668
0.02081

(0.3974, 0.4743)
(-0.194, -0.08104)
(-0.4843, -0.3706)
(-0.007035, 0.03923)
(0.05091, 0.09225)
(-0.06005, -0.01332)
(-0.005475, 0.04709)
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p21 = 0.02432 (0.0012, 0.04745)
p12 = -0.03949 (-0.06287, -0.01611)
po3 = 0.1185 (0.09164, 0.1453)

Goodness of fit:
SSE: 4.125
R-square: 0.776
Adjusted R-square: 0.7653
RMSE: 0.1477

Goodness of validation:
SSE : 2.26745
RMSE : 0.155312

13 To export this fit information to the workspace, select Fit > Save to
Workspace. Executing this command also exports other information
such as the numbers of observations and parameters, residuals, and the
fitted model.

You can treat the fitted model as a function to make predictions or evaluate
the surface at values of X and Y. For details see “Exporting a Fit to the
Workspace” on page 7-17.

14 Display the residuals plot to check the distribution of points relative to the

surface. Click the toolbar button |E or select View > Residuals Plot.

-

500 1000 1500 2000 2500 3000 |
. ¥
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05-

15 Right-click the residuals plot to select the Go to X-Z view. The X-Z view is
not required, but the view makes it easier to see to remove outliers.

16 To remove outliers, click the toolbar button i or select Tools > Exclude
Outliers.

When you move the mouse cursor to the plot, it changes to a cross-hair to
show you are in outlier selection mode.

a Click a point that you want to exclude in the surface plot or residuals
plot. Alternatively, click and drag to define a rectangle and remove all
enclosed points.

A removed plot point displays as a red star in the plots.

(I

T 1 T I
—® Puolynomial - residuals
— Excluded z vs. x, v

esiduals

EA

L e Ml i
Ol A
B

i i i i i

1000 1500 2000 2500 3000

b If you have Auto-fit selected, the Curve Fitting app refits the surface
without the point. Otherwise, you can click Fit to refit the surface.

¢ To return to rotation mode, click the toolbar button = again to switch
off Exclude Outliers mode.

17 To compare your fits side-by-side, use the tile tools. Select
Window > Left/Right Tile, or use the toolbar buttons.
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4\ Curve Fitting Tool EI

File Fit View Tools Desktop Window Help

Smoothing regression x| Polynomial x| U

Smoothing regression O 2 X Polynomial
Fit name: |Smoothing regression Interpolant Fit name: |Polynomial | Polynomial
Adata: | x i Method: Linear X data: x =) | Degrees: :3 v: ¥ 3
Y data: ¥ o | Center and sca Y data: ¥ ~ Robust: | Off
Zdata: |z hd Z data: z ~) | [¥#] Center and scale

Weights: :(none) - Weights: | (none) V: | Fit Options..

Results Results /---’___7———_____ o
Linear interpol Linear model Poly33: Ll O BUSBEY
flx,y) =p flx,y) = p00 + p10% # Excluded zvs. %,y
where x i + pl2*x*y|
and wher where x is normaliz 14
Coefficents: and where v is norr|
p = coeffi Coeffidents (with 95% N g5
po0 = 0.4141 (i i
Goodness of f L plo= -0.1401
S5E; 1.001e p0l= -0.4191 04
R-square: 1 p20 = 0.02415 - 1
Adjusted R-g pli= 0.07373 e
RMSE: NaN | || N po2= -0.02437 1000 A
p30 =  0.0219 2000 3000 0 Y
p21= 0.01545 X
pl2 = -0.03632
p03=  0.1177 ¢ R
~ r e E———
Goodness of fit: /_/-/' e Polynomial - residuals
SSE: 5.966 0.4 4 ol +# Excluded zvs. x, ¥
R-square: 0.776 i oL il T T
Adjusted R-square: 0. 0.2
RMSE: 0,1457 =1
N 1] ;
.
]
02 . e '
044 ]~ *e |
LX _— Py
. o A0000 6 saonn] ST Pl Y
/" <l r .
Table of Fits S mp
Fit name = Data Fit type S5E R-square DFE Adj R-sq RMSE # Coeff Validation... Validation... Validation...
M Polyno... [zvs.xy  |poly33 |5.9663 o760 281 o.7688 Ip.1457 10 | |
@ Smoothi.jzvs.xy  |linearinterp [1.0008e-30 1 o [NaM [NaM 203 \ | |

18 Review the information in the Table of Fits. Compare goodness-of-fit
statistics for all fits in your session to determine which is best.
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19 To save your interactive surface fitting session, select File > Save Session.
You can save and reload sessions to access multiple fits. The session file
contains all the fits and variables in your session and remembers your
layout.

20 After interactively creating and comparing fits, you can generate code for
all fits and plots in your Curve Fitting app session. Select File > Generate
Code.

The Curve Fitting app generates code from your session and displays the
file in the MATLAB Editor. The file includes all fits and plots in your
current session.

21 Save the file with the default name, createFits.m.

22 You can recreate your fits and plots by calling the file from the command
line (with your original data or new data as input arguments). In this case,
your original variables still appear in the workspace.

Highlight and evaluate the first line of the file (excluding the word
function). Either right-click and select Evaluate, press F9, or copy and
paste the following to the command line:

[fitresult, gof] = createFits(x, y, z, xv, yv, zv)

The function creates a figure window for each fit you had in your session.
Observe that the polynomial fit figure shows both the surface and
residuals plots that you created interactively in the Curve Fitting app.

If you want you can use the generated code as a starting point to change
the surface fits and plots to fit your needs. For a list of methods you
can use, see sfit.

For more information on all fit settings and tools for comparing fits, see:

® “Create Multiple Fits in Curve Fitting App” on page 2-14

¢ “Linear and Nonlinear Regression”

® “Interpolation”

® “Smoothing”

* “Fit Postprocessing”
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Programmatic Curve and
Surface Fitting

e “Curve and Surface Fitting” on page 3-2
® “Polynomial Curve Fitting” on page 3-5
e “Curve and Surface Fitting Objects and Methods” on page 3-13



3 Programmatic Curve and Surface Fitting

Curve and Surface Fitting

In this section...

“Fitting a Curve” on page 3-2

“Fitting a Surface” on page 3-2

“Model Types and Fit Analysis” on page 3-3
“Workflow for Command Line Fitting” on page 3-3

Fitting a Curve
To programmatically fit a curve, follow the steps in this simple example:

1 Load some data.

load hahnt

Create a fit using the fit function, specifying the variables and a model
type (in this case rat23 is the model type).

f = fit( temp, thermex, 'rat23' )

Plot your fit and the data.

plot( f, temp, thermex )
f( 600 )

For an example comparing various polynomial fits, see “Polynomial Curve
Fitting” on page 3-5.

Fitting a Surface
To programmatically fit a surface, follow the steps in this simple example:

1 Load some data.

load franke
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2 Create a fit using the fit function, specifying the variables and a model
type (in this case poly23 is the model type).

f = fit( [x, y], z, 'poly23' )
3 Plot your fit and the data.
plot(f, [x,yl, z)

For an example fitting custom equations, see “Surface Fitting With Custom
Equations to Biopharmaceutical Data” on page 5-50.

Model Types and Fit Analysis

For details and examples of specific model types and fit analysis, see the
following sections:

1 “Linear and Nonlinear Regression”
2 “Interpolation”
3 “Smoothing”

4 “Fit Postprocessing”

Workflow for Command Line Fitting

Curve Fitting Toolbox software provides a variety of methods for data analysis
and modeling.

A typical analysis using curve fitting methods proceeds as follows:

1 Import your data into the MATLAB workspace using the load command
(if your data has previously been stored in MATLAB variables) or any of
the more specialized MATLAB functions for reading data from particular
file types.

2 (Optional) If your data is noisy, you might want to smooth it using the
smooth function. Smoothing is used to identify major trends in the data
that can assist you in choosing an appropriate family of parametric models.
If a parametric model is not evident or appropriate, smoothing can be an
end in itself, providing a nonparametric fit of the data.
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Note Smoothing estimates the center of the distribution of the response
at each predictor. It invalidates the assumption that errors in the data
are independent, and so also invalidates the methods used to compute
confidence and prediction intervals. Accordingly, once a parametric model
1s 1dentified through smoothing, the original data should be passed to the
fit function.

3 Specify a parametric model for the data—either a Curve Fitting Toolbox
library model or a custom model that you define. You can specify the model
by passing a string or expression to the fit function or (optional) with a
fittype object you create with the fittype function.

To view available library models, see “List of Library Models for Curve
and Surface Fitting” on page 4-13.

4 (Optional) You can create a fit options structure for the fit using the
fitoptions function. Fit options specify things like weights for the data,
fitting methods, and low-level options for the fitting algorithm.

5 (Optional) You can create an exclusion rule for the fit using the
excludedata function. Exclusion rules indicate which data values will be
treated as outliers and excluded from the fit.

6 You pass the data, a model (string, expression or fittype object), and
(optionally) a fit options structure and an exclusion rule, to the fit function
to perform the fit.

The fit function returns a cfit (for curves) or sfit (for surfaces) object
that encapsulates the computed coefficients and the fit statistics.

7 You can then postprocess the cfit and sfit objects returned by the
fit function, by passing them to a variety of functions, such as feval,
differentiate, integrate, plot, coeffvalues, probvalues, confint,
and predint.

For more details on functions, see “Curve and Surface Fitting Objects and
Methods” on page 3-13.
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Polynomial Curve Fitting

This example shows how to fit polynomials up to sixth degree to some census
data using Curve Fitting Toolbox™. It also shows how to fit a single-term
exponential equation and compare this to the polynomial models.

The steps show how to:

¢ Load data and create fits using different library models.

e Search for the best fit by comparing graphical fit results, and by comparing
numerical fit results including the fitted coefficients and goodness of fit
statistics.

Load and Plot the Data

The data for this example is the file census.mat
load census

The workspace contains two new variables:

e cdate i1s a column vector containing the years 1790 to 1990 in 10-year
increments.

® pop is a column vector with the U.S. population figures that correspond to

the years in cdate .

whos cdate pop
plot( cdate, pop, '0' )

Name Size Bytes Class Attributes
cdate 21x1 168 double
pop 21x1 168 double

Create and Plot a Quadratic

3-5



3 Programmatic Curve and Surface Fitting

3-6

Use the fit function to fit a a polynomial to data. You specify a quadratic,

or second-degree polynomial, with the string 'poly2'. The first output from
fit is the polynomial, and the second output, gof, contains the goodness of fit
statistics you will examine in a later step.

[population2, gof] = fit( cdate, pop, 'poly2' );
To plot the fit, use the plot method.

plot( population2, cdate, pop );
% Move the legend to the top left corner.
legend( 'Location', 'NorthWest' );

Create and Plot a Selection of Polynomials

To fit polynomials of different degrees, change the fittype string, e.g., for a
cubic or third-degree polynomial use 'poly3'. The scale of the input, cdate,
1s quite large, so you can obtain better results by centering and scaling the
data. To do this, use the 'Normalize' option.

population3 = fit( cdate, pop, 'poly3', 'Normalize', 'on' );
population4 = fit( cdate, pop, 'poly4', 'Normalize', 'on' );
population5 = fit( cdate, pop, 'poly5', 'Normalize', 'on' );
population6é = fit( cdate, pop, 'poly6', 'Normalize', 'on' );

A simple model for population growth tells us that an exponential equation
should fit this census data well. To fit a single term exponential model, use
"expl1' as the fittype.

populationExp = fit( cdate, pop, ‘'expl' );

Plot all the fits at once, and add a meaningful legend in the top left corner of
the plot.

hold on

plot( population3, 'b' )

plot( population4, 'g' );
plot( population5, 'm' )

plot( population6, 'b--'
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plot( populationExp, 'r--' );

hold off
legend( 'cdate v pop', 'poly2', 'poly3', 'poly4', 'poly5', 'poly6',
'Location', 'NorthWest' );

Plot the Residuals to Evaluate the Fit

To plot residuals, specify 'residuals' as the plot type in the plot method.

plot( population2, cdate, pop, 'residuals' );

The fits and residuals for the polynomial equations are all similar, making it
difficult to choose the best one.

If the residuals display a systematic pattern, it is a clear sign that the model
fits the data poorly.

plot( populationExp, cdate, pop, 'residuals' );

The fit and residuals for the single-term exponential equation indicate it
is a poor fit overall. Therefore, it is a poor choice and you can remove the
exponential fit from the candidates for best fit.

Examine Fits Beyond the Data Range

Examine the behavior of the fits up to the year 2050. The goal of fitting the
census data is to extrapolate the best fit to predict future population values.

By default, the fit is plotted over the range of the data. To plot a fit over
a different range, set the x-limits of the axes before plotting the fit. For
example, to see values extrapolated from the fit, set the upper x-limit to 2050.

plot( cdate, pop, '0' );
xlim( [1900, 2050] );
hold on

"expl’',
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plot( population6 );
hold off

Examine the plot. The behavior of the sixth-degree polynomial fit beyond the
data range makes it a poor choice for extrapolation and you can reject this fit.

Plot Prediction Intervals

To plot prediction intervals, use 'predobs' or 'predfun' as the plot type.
For example, to see the prediction bounds for the fifth-degree polynomial for
a new observation up to year 2050:

plot( cdate, pop, '0' );

xlim( [1900, 2050] )

hold on

plot( population5, 'predobs' );
hold off

Plot prediction intervals for the cubic polynomial up to year 2050:

plot( cdate, pop, '0' );

xlim( [1900, 2050] )

hold on

plot( population3, 'predobs' )
hold off

Examine Goodness-of-Fit Statistics

The struct gof shows the goodness-of-fit statistics for the 'poly2' fit. When
you created the 'poly2' fit with the fit function in an earlier step, you
specified the gof output argument.

gof
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sse: 159.0293
rsquare: 0.9987
dfe: 18
adjrsquare: 0.9986

rmse: 2.9724

Examine the sum of squares due to error (SSE) and the adjusted R-square
statistics to help determine the best fit. The SSE statistic is the least-squares
error of the fit, with a value closer to zero indicating a better fit. The adjusted
R-square statistic is generally the best indicator of the fit quality when you
add additional coefficients to your model.

The large SSE for 'exp1' indicates it is a poor fit, which you already
determined by examining the fit and residuals. The lowest SSE value is
associated with 'poly6'. However, the behavior of this fit beyond the data
range makes it a poor choice for extrapolation, so you already rejected this fit
by examining the plots with new axis limits.

The next best SSE value is associated with the fifth-degree polynomial fit,
'poly5', suggesting it might be the best fit. However, the SSE and adjusted
R-square values for the remaining polynomial fits are all very close to each
other. Which one should you choose?

Compare the Coefficients and Confidence Bounds to Determine the Best Fit

Resolve the best fit issue by examining the coefficients and confidence bounds
for the remaining fits: the fifth-degree polynomial and the quadratic.

Examine population2 and population5 by displaying the models, the fitted
coefficients, and the confidence bounds for the fitted coefficients:

population2

population2 =

Linear model Poly2:
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population2(x) = p1*x"2 + p2*x + p3
Coefficients (with 95% confidence bounds):

p1 = 0.006541 (0.006124, 0.006958)
p2 = -23.51 (-25.09, -21.93)
p3 = 2.113e+04 (1.964e+04, 2.262e+04)
population5
population5 =

Linear model Poly5:

population5(x) = p1*x"5 + p2*x"4 + p3*x"3 + p4*x"2 + p5*Xx + pb6
where x is normalized by mean 1890 and std 62.05

Coefficients (with 95% confidence bounds):

p1 = 0.5877 (-2.305, 3.48)
p2 = 0.7047 (-1.684, 3.094)
p3 = -0.9193 (-10.19, 8.356)
pa = 23.47 (17.42, 29.52)
p5 = 74.97 (68.37, 81.57)
p6 = 62.23 (59.51, 64.95)

You can also get the confidence intervals by using confint :

ci confint( population5 )

ci

-2.3046 -1.6841 -10.1943 17.4213 68.3655 59.5102
3.4801 3.0936 8.3558 29.5199 81.5696 64.9469

The confidence bounds on the coefficients determine their accuracy. Check
the fit equations (e.g. f(x)=p1*x+p2*x... ) to see the model terms for
each coefficient. Note that p2 refers to the p2*x term in 'poly2' and the
p2*x~4 term in 'poly5'. Do not compare normalized coefficients directly with
non-normalized coefficients.
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The bounds cross zero on the p1, p2, and p3 coefficients for the fifth-degree
polynomial. This means you cannot be sure that these coefficients differ from
zero. If the higher order model terms may have coefficients of zero, they are
not helping with the fit, which suggests that this model over fits the census
data.

The fitted coefficients associated with the constant, linear, and quadratic
terms are nearly identical for each normalized polynomial equation. However,
as the polynomial degree increases, the coefficient bounds associated with the
higher degree terms cross zero, which suggests over fitting.

However, the small confidence bounds do not cross zero on p1, p2, and p3
for the quadratic fit, indicating that the fitted coefficients are known fairly
accurately.

Therefore, after examining both the graphical and numerical fit results, you
should select the quadratic population2 as the best fit to extrapolate the
census data.

Evaluate the Best Fit at New Query Points

Now you have selected the best fit, population2, for extrapolating this census
data, evaluate the fit for some new query points:

cdateFuture = (2000:10:2020)."';
popFuture = population2( cdateFuture )

popFuture =
274.6221

301.8240
330.3341

To compute 95% confidence bounds on the prediction for the population in
the future, use the predint method:

ci = predint( population2, cdateFuture, 0.95, 'observation' )
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ci =

266.9185 282.3257
293.5673 310.0807
321.3979 3839.2702

Plot the predicted future population, with confidence intervals, against the
fit and data.

plot( cdate, pop, '0' );

xlim( [1900, 2040] )

hold on

plot( population2 )

h = errorbar( cdateFuture, popFuture, popFuture-ci(:,1), ci(:,2)-popFuture,

hold off
legend( 'cdate v pop', 'poly2', 'prediction',
‘Location', 'NorthWest' )
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Curve and Surface Fitting Objects and Methods

In this section...

“Curve Fitting Objects” on page 3-13
“Curve Fitting Methods” on page 3-15
“Surface Fitting Objects and Methods” on page 3-18

This section describes how to use Curve Fitting Toolbox functions from the
command-line or to write programs for curve and surface fitting applications.

The Curve Fitting app allows convenient, interactive use of Curve Fitting
Toolbox functions, without programming. You can, however, access Curve
Fitting Toolbox functions directly, and write programs that combine curve
fitting functions with MATLAB functions and functions from other toolboxes.
This allows you to create a curve fitting environment that is precisely suited
to your needs.

Models and fits in the Curve Fitting app are managed internally as curve
fitting objects. Objects are manipulated through a variety of functions
called methods. You can create curve fitting objects, and apply curve fitting
methods, outside of the Curve Fitting app.

Curve Fitting Objects

In MATLAB programming, all workspace variables are objects of a particular
class. Familiar examples of MATLAB classes are double, char, and
function_handle. You can also create custom MATLAB classes, using
object-oriented programming.

Methods are functions that operate exclusively on objects of a particular
class. Data types package together objects and methods so that the methods
operate exclusively on objects of their own type, and not on objects of other
types. A clearly defined encapsulation of objects and methods is the goal of
object-oriented programming.

Curve Fitting Toolbox software provides you with new MATLAB data types
for performing curve fitting:
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e fittype — Objects allow you to encapsulate information describing a
parametric model for your data. Methods allow you to access and modify
that information.

e cfit and sfit — Two subtypes of fittype, for curves and surfaces. Objects
capture information from a particular fit by assigning values to coefficients,
confidence intervals, fit statistics, etc. Methods allow you to post-process
the fit through plotting, extrapolation, integration, etc.

fFittype
objects

Because cfit is a subtype of fittype, cfit inherits all fittype methods.
In other words, you can apply fittype methods to both fittype and cfit
objects, but cfit methods are used exclusively with cfit objects. Similarly
for sfit objects.

As an example, the fittype method islinear, which determines if a model
is linear or nonlinear, would apply equally well before or after a fit; that is,
to both fittype and cfit objects. On the other hand, the cfit methods
coeffvalues and confint, which, respectively, return fit coefficients and
their confidence intervals, would make no sense if applied to a general
fittype object which describes a parametric model with undetermined
coefficients.

Curve fitting objects have properties that depend on their type, and also on
the particulars of the model or the fit that they encapsulate. For example, the
following code uses the constructor methods for the two curve fitting types

to create a fittype object f and a cfit object c:
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f = fittype('a*x"2+b*exp(n*x)"')
f:
General model:
f(a,b,n,x) = a*x"2+b*exp(n*x)
¢ = cfit(f,1,10.3,-1e2)
C:

General model:
c(x) = a*x"2+b*exp(n*x)

Coefficients:
a= 1
b = 10.3
n = -100

Note that the display method for fittype objects returns only basic
information, piecing together outputs from formula and indepnames.

cfit and fittype objects are evaluated at predictor values x using feval.
You can call feval indirectly using the following functional syntax:

cfun(x) % cfit objects;
ffun(coefi,coef2,..

y =
y

Curve Fitting Methods

.,X) % fittype objects;

Curve fitting methods allow you to create, access, and modify curve fitting
objects. They also allow you, through methods like plot and integrate,
to perform operations that uniformly process the entirety of information

encapsulated in a curve fitting object.

The methods listed in the following table are available for all fittype objects,

including cfit objects.

Fit Type Method Description

argnames Get input argument names

category Get fit category

coeffnames Get coefficient names

dependnames Get dependent variable name

feval Evaluate model at specified predictors
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Fit Type Method Description

fittype Construct fittype object

formula Get formula string

indepnames Get independent variable name
islinear Determine if model is linear

numargs Get number of input arguments
numcoeffs Get number of coefficients

probnames Get problem-dependent parameter names
setoptions Set model fit options

type Get name of model

The methods listed in the following table are available exclusively for cfit

objects.
Curve Fit Method Description
cfit Construct cfit object
coeffvalues Get coefficient values
confint Get confidence intervals for fit coefficients
differentiate Differentiate fit
integrate Integrate fit
plot Plot fit
predint Get prediction intervals
probvalues Get problem-dependent parameter values

A complete list of methods for a curve fitting object can be obtained with the
MATLAB methods command. For example,

f = fittype('a*x"2+b*exp(n*x)"');
methods (T)

Methods for class fittype:
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argnames dependnames fittype islinear probnames
category feval formula numargs setoptions
coeffnames fitoptions indepnames numcoeffs type

Note that some of the methods listed by methods do not appear in the

tables above, and do not have reference pages in the Curve Fitting Toolbox
documentation. These additional methods are generally low-level operations
used by the Curve Fitting app, and not of general interest when writing curve
fitting applications.

There are no global accessor methods, comparable to getfield and setfield,
available for fittype objects. Access is limited to the methods listed above.
This is because many of the properties of fittype objects are derived from
other properties, for which you do have access. For example,

f = fittype('a*cos( b*x-c )')
f =
General model:
f(a,b,c,x) = a*cos( b*x-c )
formula(f)
ans =

a*cos( b*x-c )

argnames (f)
ans =

g

b

o

Ty

You construct the fittype object f by giving the formula, so you do have
write access to that basic property of the object. You have read access to
that property through the formula method. You also have read access to the
argument names of the object, through the argnames method. You don’t,
however, have direct write access to the argument names, which are derived
from the formula. If you want to set the argument names, set the formula.

3-17



3 Programmatic Curve and Surface Fitting

3-18

Surface Fitting Objects and Methods

Surface Fitting Objects and Methods

The surface fit object (sfit) stores the results from a surface fitting operation,
making it easy to plot and analyze fits at the command line.

Like cfit objects, sfit objects are a subclass of fittype objects, so they
inherit all the same methods of fittype listed in “Curve Fitting Methods”
on page 3-15.

sfit objects also provide methods exclusively for sfit objects. See sfit.

One way to quickly assemble code for surface fits and plots into useful
programs is to generate a file from a session in the Curve Fitting app. In
this way, you can transform your interactive analysis of a single data set
into a reusable function for command-line analysis or for batch processing of
multiple data sets. You can use the generated file without modification, or
edit and customize the code as needed. See “Generate Code and Export Fits to
the Workspace” on page 7-16.
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* “Parametric Fitting” on page 4-2

e “List of Library Models for Curve and Surface Fitting” on page 4-13
® “Polynomial Models” on page 4-19

¢ “Exponential Models” on page 4-38

® “Fourier Series” on page 4-47

® “Gaussian Models” on page 4-59

* “Power Series” on page 4-63

e “Rational Polynomials” on page 4-68
® “Sum of Sines Models” on page 4-75
* “Weibull Distributions” on page 4-78
® “Least-Squares Fitting” on page 4-82
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Parametric Fitting

In this section...

“Parametric Fitting with Library Models” on page 4-2
“Selecting a Model Type Interactively” on page 4-3
“Selecting Model Type Programmatically” on page 4-5

“Using Normalize or Center and Scale” on page 4-6

“Specifying Fit Options and Optimized Starting Points” on page 4-7

Parametric Fitting with Library Models

Parametric fitting involves finding coefficients (parameters) for one or more
models that you fit to data. The data is assumed to be statistical in nature
and is divided into two components:

data = deterministic component + random component

The deterministic component is given by a parametric model and the random
component is often described as error associated with the data:

data = parametric model + error

The model is a function of the independent (predictor) variable and one or
more coefficients. The error represents random variations in the data that
follow a specific probability distribution (usually Gaussian). The variations
can come from many different sources, but are always present at some level
when you are dealing with measured data. Systematic variations can also
exist, but they can lead to a fitted model that does not represent the data well.

The model coefficients often have physical significance. For example, suppose
you collected data that corresponds to a single decay mode of a radioactive
nuclide, and you want to estimate the half-life (T,) of the decay. The law of
radioactive decay states that the activity of a radioactive substance decays
exponentially in time. Therefore, the model to use in the fit is given by

y=ye™
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where y, is the number of nuclei at time ¢ = 0, and A is the decay constant.
The data can be described by

data = yoe_’u +error

Both y, and A are coefficients that are estimated by the fit. Because T,

= In(2)/A, the fitted value of the decay constant yields the fitted half-life.
However, because the data contains some error, the deterministic component
of the equation cannot be determined exactly from the data. Therefore, the
coefficients and half-life calculation will have some uncertainty associated

with them. If the uncertainty is acceptable, then you are done fitting the data.

If the uncertainty is not acceptable, then you might have to take steps to
reduce it either by collecting more data or by reducing measurement error
and collecting new data and repeating the model fit.

With other problems where there is no theory to dictate a model, you might
also modify the model by adding or removing terms, or substitute an entirely
different model.

The Curve Fitting Toolbox parametric library models are described in the
following sections.

Selecting a Model Type Interactively
Select a model type to fit from the drop-down list in the Curve Fitting app.

Polynomial -
Degree: |1 -
Robust: | Off -

Center and scale

Fit Options...

4-3



4 |incar and Nonlinear Regression

What fit types can you use for curves or surfaces? Based on your selected data,
the fit category list shows either curve or surface categories. The following

table describes the options for curves and surfaces.

Fit Category

Curves

Surfaces

Regression Models

Polynomial Yes (up to degree 9) Yes (up to degree 5)

Exponential Yes

Fourier Yes

Gaussian Yes

Power Yes

Rational Yes

Sum of Sine Yes

Weibull Yes

Interpolation

Interpolant Yes Yes
Methods: Methods:
Nearest neighbor Nearest neighbor
Linear Linear
Cubic Cubic
Shape-preserving Biharmonic
(PCHIP) Thin-plate spline

Smoothing

Smoothing Spline Yes

Lowess Yes

Custom

Custom Equation Yes Yes

“Custom Linear Yes

Fitting” on page 5-8
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For all fit categories, look in the Results pane to see the model terms, the
values of the coefficients, and the goodness-of-fit statistics.

Tip If your fit has problems, messages in the Results pane help you identify
better settings.

Selecting Fit Settings

The Curve Fitting app provides a selection of fit types and settings that you
can change to try to improve your fit. Try the defaults first, then experiment
with other settings.

For an overview of how to use the available fit options, see “Specifying Fit
Options and Optimized Starting Points” on page 4-7.

You can try a variety of settings within a single fit figure, and you can

also create multiple fits to compare. When you create multiple fits you can
compare different fit types and settings side by side in the Curve Fitting app.
See “Create Multiple Fits in Curve Fitting App” on page 2-14.

Selecting Model Type Programmatically

You can specify a library model name as a string when you call the fit
function. For example, to specify a quadratic poly2:

f = fit( x, y, 'poly2' )

See “List of Library Models for Curve and Surface Fitting” on page 4-13 to
view all available library model names.

You can also use the fittype function to construct a fittype object for a
library model, and use the fittype as an input to the fit function.

Use the fitoptions function to find out what parameters you can set, for
example:

fitoptions(poly2)
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For examples, see the sections for each model type, listed in the table in
“Selecting a Model Type Interactively” on page 4-3. For details on all the
functions for creating and analysing models, see “Curve and Surface Fitting”
on page 3-2.

Using Normalize or Center and Scale

Most model types in the Curve Fitting app share the Center and scale
option. When you select this option, the tool refits with the data centered and
scaled, by applying the Normalize setting to the variables. At the command
line, you can use Normalize as an input argument to the fitoptions function.
See the fitoptions reference page.

Generally, it is a good 1dea to normalize inputs (also known as predictor data),
which can alleviate numerical problems with variables of different scales.
For example, suppose your surface fit inputs are engine speed with a range
of 500—4500 r/min and engine load percentage with a range of 0—1. Then,
Center and scale generally improves the fit because of the great difference
in scale between the two inputs. However, if your inputs are in the same
units or similar scale (e.g., eastings and northings for geographic data), then
Center and scale is less useful. When you normalize inputs with this option,
the values of the fitted coefficients change when compared to the original data.

If you are fitting a curve or surface to estimate coefficients, or the coefficients
have physical significance, clear the Center and scale check box. The Curve
Fitting app plots use the original scale with or without the Center and
scale option.

At the command line, to set the option to center and scale the data before
fitting, create the default fit options structure, set Normalize to on, then fit
with the options:

options = fitoptions;
options.Normal = 'on';
options
options =
Normalize: 'on'
Exclude: [1x0 double]
Weights: [1x0 double]
Method: 'None’



Parametric Fitting

load census
f1 = fit(cdate,pop, 'poly3',options)

Specifying Fit Options and Optimized Starting Points

e “About Fit Options” on page 4-7

* “Fitting Method and Algorithm” on page 4-8

e “Finite Differencing Parameters” on page 4-9

¢ “Fit Convergence Criteria” on page 4-9

e “Coefficient Parameters” on page 4-10

® “Optimized Starting Points and Default Constraints” on page 4-10
® “Specifying Fit Options at the Command Line” on page 4-11

About Fit Options

Interactive fit options are described in the following sections. To specify
the same fit options programmatically, see “Specifying Fit Options at the
Command Line” on page 4-11.

To specify fit options interactively in the Curve Fitting app, click the Fit
Options button to open the Fit Options dialog box. All fit categories except
interpolants and smoothing splines have configurable fit options.

The available options depend on whether you are fitting your data using a
linear model, a nonlinear model, or a nonparametric fit type:

e All the options described next are available for nonlinear models.

¢ Lower and Upper coefficient constraints are the only fit options available
in the dialog box for polynomial linear models. For polynomials you can
set Robust in the Curve Fitting app, without opening the Fit Options
dialog box.

* Nonparametric fit types have no additional fit options dialog box
(interpolant, smoothing spline, and lowess).



4 |incar and Nonlinear Regression

The fit options for the single-term exponential are shown next. The coefficient
starting values and constraints are for the census data.

ilethod: mHonlinearLeastSguares
Robust |off =1
Algarithim: |Tru5t—Regi|:|n j
DifMinChange: | 1.0E-8
DiffMaxChanoe: | 0.1
MaxFunEvals: | GO0
Maxlter: | 400
TolFun: | 1.0E-6
Tal: | 1.0E-6
Linknowns| StartPoint| Lower Llpper

a 49.04e-15 -] Inf
1] 1.91e-02 -1rf] Inf]

Fitting Method and Algorithm

¢ Method — The fitting method.

Fitting method and algorithm

Finite differencing parameters

Fit convergence criteria

Coefficient parameters

The method is automatically selected based on the library or custom model
you use. For linear models, the method is LinearLeastSquares. For
nonlinear models, the method is NonlinearLeastSquares.

¢ Robust — Specify whether to use the robust least-squares fitting method.

= Off — Do not use robust fitting (default).
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= On — Fit with the default robust method (bisquare weights).
= LAR — Fit by minimizing the least absolute residuals (LAR).

= Bisquare — Fit by minimizing the summed square of the residuals, and
reduce the weight of outliers using bisquare weights. In most cases, this
is the best choice for robust fitting.

® Algorithm — Algorithm used for the fitting procedure:

= Trust-Region — This is the default algorithm and must be used if you
specify Lower or Upper coefficient constraints.

= Levenberg-Marquardt — If the trust-region algorithm does not
produce a reasonable fit, and you do not have coefficient constraints, try
the Levenberg-Marquardt algorithm.

Finite Differencing Parameters

¢ DiffMinChange — Minimum change in coefficients for finite difference
Jacobians. The default value is 108,

¢ DiffMaxChange — Maximum change in coefficients for finite difference
Jacobians. The default value is 0.1.

Note that DiffMinChange and DiffMaxChange apply to:

® Any nonlinear custom equation, that is, a nonlinear equation that you write
® Some of the nonlinear equations provided with Curve Fitting Toolbox

software

However, DiffMinChange and DiffMaxChange do not apply to any linear
equations.

Fit Convergence Criteria

e MaxFunEvals — Maximum number of function (model) evaluations
allowed. The default value is 600.

¢ MaxIter — Maximum number of fit iterations allowed. The default value
1s 400.
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¢ TolFun — Termination tolerance used on stopping conditions involving
the function (model) value. The default value is 107,

¢ TolX — Termination tolerance used on stopping conditions involving the
coefficients. The default value is 10,

Coefficient Parameters

¢ Unknowns — Symbols for the unknown coefficients to be fitted.

e StartPoint — The coefficient starting values. The default values depend
on the model. For rational, Weibull, and custom models, default values are
randomly selected within the range [0,1]. For all other nonlinear library
models, the starting values depend on the data set and are calculated
heuristically. See optimized starting points below.

* Lower — Lower bounds on the fitted coefficients. The tool only uses the
bounds with the trust region fitting algorithm. The default lower bounds
for most library models are - Inf, which indicates that the coefficients are
unconstrained. However, a few models have finite default lower bounds.
For example, Gaussians have the width parameter constrained so that it
cannot be less than 0. See default contraints below.

e Upper — Upper bounds on the fitted coefficients. The tool only uses the
bounds with the trust region fitting algorithm. The default upper bounds
for all library models are Inf, which indicates that the coefficients are
unconstrained.

For more information about these fit options, see the 1sqcurvefit function in
the Optimization Toolbox documentation.

Optimized Starting Points and Default Constraints

The default coefficient starting points and constraints for library and custom
models are shown in the next table. If the starting points are optimized,
then they are calculated heuristically based on the current data set. Random
starting points are defined on the interval [0,1] and linear models do not
require starting points.

If a model does not have constraints, the coefficients have neither a lower
bound nor an upper bound. You can override the default starting points and
constraints by providing your own values using the Fit Options dialog box.
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Default Starting Points and Constraints

Model Starting Points Constraints
Custom linear N/A None
Custom nonlinear Random None
Exponential Optimized None
Fourier Optimized None
Gaussian Optimized >0
Polynomial N/A None
Power Optimized None
Rational Random None
Sum of Sine Optimized b,>0
Weibull Random a,b>0

Note that the sum of sines and Fourier series models are particularly sensitive
to starting points, and the optimized values might be accurate for only a few
terms in the associated equations.

Specifying Fit Options at the Command Line

Create the default fit options structure and set the option to center and scale
the data before fitting:

options = fitoptions;
options.Normal = 'on';
options
options =
Normalize: 'on'
Exclude: [1x0 double]
Weights: [1x0 double]
Method: 'None’

Modifying the default fit options structure is useful when you want to set the
Normalize, Exclude, or Weights fields, and then fit your data using the same
options with different fitting methods. For example:

4-11



4 |incar and Nonlinear Regression

4-12

load census

f1 = fit(cdate,pop, 'poly3',options);
f2 = fit(cdate,pop, 'expl1',options);
f3 = fit(cdate,pop, 'cubicsp',options);

Data-dependent fit options are returned in the third output argument of the
fit function. For example, the smoothing parameter for smoothing spline is
data-dependent:

[f,gof,out] = fit(cdate,pop, 'smooth');

smoothparam = out.p

smoothparam
0.0089

Use fit options to modify the default smoothing parameter for a new fit:

options = fitoptions('Method', 'Smooth', 'SmoothingParam',0.0098);
[f,gof,out] = fit(cdate,pop, 'smooth',options);

For more details on using fit options, see the fitoptions reference page.
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List of Library Models for Curve and Surface Fitting

In this section...
“Use Library Models to Fit Data” on page 4-13

“Library Model Types” on page 4-13

“Model Names and Equations” on page 4-14

Use Library Models to Fit Data

You can use the Curve Fitting Toolbox library of models for data fitting with
the fit function. You use library model names as input arguments in the fit,
fitoptions, and fittype functions.

Library Model Types

The following tables describe the library model types for curves and surfaces.
¢ Use the links in the table for examples and detailed information on each
library type.

¢ If you want a quick reference of model names for input arguments to the
fit function, see “Model Names and Equations” on page 4-14.

Library Model Description
Types for Curves
distribution Distribution models such as Weibull. See “Weibull

Distributions” on page 4-78.

exponential Exponential function and sum of two exponential
functions. See “Exponential Models” on page 4-38.

fourier Up to eight terms of Fourier series. See “Fourier
Series” on page 4-47.

gaussian Sum of up to eight Gaussian models. See “Gaussian
Models” on page 4-59.

interpolant Interpolating models, including linear, nearest
neighbor, cubic spline, and shape-preserving cubic
spline. See “Nonparametric Fitting” on page 6-2.
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Library Model
Types for Curves

Description

polynomial Polynomial models, up to degree nine. See
“Polynomial Models” on page 4-19.

power Power function and sum of two power functions.
See “Power Series” on page 4-63.

rational Rational equation models, up to 5th degree/5th
degree (i.e., up to degree 5 in both the numerator
and the denominator). See “Rational Polynomials”
on page 4-68.

sin Sum of up to eight sin functions. See “Sum of Sines
Models” on page 4-75.

spline Cubic spline and smoothing spline models. See

“Nonparametric Fitting” on page 6-2.

Library Model
Types for Surfaces

Description

interpolant Interpolating models, including linear, nearest
neighbor, cubic spline, biharmonic, and thin-plate
spline interpolation. See “Interpolants” on page 6-3.

lowess Lowess smoothing models. See “Lowess Smoothing”
on page 6-17.

polynomial Polynomial models, up to degree five. See

“Polynomial Models” on page 4-19.

Model Names and Equations

To specify the model you want to fit, consult the following tables for a model
name to use as an input argument to the fit function. For example, to specify
a quadratic curve with model name “poly2” :

f = fit(x, y, 'poly2")
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Polynomial Model Names and Equations

Examples of Polynomial Model | Equations
Names for Curves

poly1 Y = p1*x+p2

poly2 Y = p1*x"2+p2*x+p3

poly3 Y = p1*x"3+p2*x"2+...+p4
...etc., up to poly9 Y = p1*x"9+p2*x~8+...+p10

For polynomial surfaces, model names are 'polyij', where i is the degree in
x and j is the degree in y. The maximum for both i and j is five. The degree
of the polynomial is the maximum of i and j. The degree of x in each term
will be less than or equal to i, and the degree of y in each term will be less
than or equal to j. See the following table for some example model names and
equations, of many potential examples.

Examples of Polynomial Model | Equations

Names for Surfaces

poly21 Z = p00 + p10*x + pO1*y +
P20*x"2 + pli*x*y

poly13 Z = p00 + p10*x + pO1*y +
pl1*x*y + p02*y~2 + p12*x*y 2
+ p03*y~3

poly55 Z = p00 + p10*x + pO1*y +...+
pl14*x*y~4 + p05*y~5

Distribution Model Name and Equation

Distribution Model Names Equations
weibull Y = a*b*x”~(b-1)*exp(-a*x"b)
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Exponential Model Names and Equations

Exponential Model Names Equations
expi Y = a*exp(b*x)
exp2 Y = a*exp(b*x)+c*exp(d*x)

Fourier Series Model Names and Equations

Fourier Series Model Names Equations
fourieri Y = a0+al*cos(x*p)+bi*sin(x*p)
fourier2 Y =

a0+a1*cos(x*p)+b1*sin(x*p)...
+a2*Cc0oSs (2*x*p)+b2*sin(2*x*p)

fourier3 Y =
a0+a1*cos(x*p)+b1*sin(x*p)...
+a3*cos (3*x*p)+b3*sin(3*x*p)

...etc., up to fouriers8 Y =
a0+ail*cos(x*p)+b1*sin(x*p)...
+a8*cos(8*x*p)+b8*sin(8*x*p)

Where p = 2*pi/(max(xdata)-min(xdata)).

Gaussian Model Names and Equations

Gaussian Model Names Equations
gaussi Y = alt*exp(-((x-b1)/c1)"2)
gauss?2 Y =

al*exp(-((x-b1)/c1)"2)+a2*...
exp(-((x-b2)/c2)"2)

gauss3 Y = at*exp(-((x-bt1)/c1)"2)+...
+a3*exp(-((x-b3)/c3)"2)

...etc., up to gauss8 Y = at*exp(-((x-b1)/c1)"2)
+... +a8*exp(-((x-b8)/c8)"2)
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Power Model Names and Equations

Power Model Names Equations
poweri Y = a*x"b
power2 Y = a*x"b+c

Rational Model Names and Equations

Rational models are polynomials over polynomials with the leading coefficient
of the denominator set to 1. Model names are ratij, where i is the degree of
the numerator and j is the degree of the denominator. The degrees go up to

five for both the numerator and the denominator.

Examples of Rational Model Equations

Names

rat02 Y = (p1)/(x"2+q1*x+q2)

rat21 Y = (p1*x"2+p2*x+p3) / (x+ql)

rats55 Y =
(p1*x°5+...+p6) / (x"5+...+05)

Sum of Sine Model Names and Equations

Sum of Sine Model Names

Equations

sini Y = ail*sin(b1*x+c1)

sin2 Y = ail*sin(b1*x+c1)+a2*sin...
(b2*x+c2)

sin3 Y = at*sin(b1*x+c1)+...

+a3*sin(b3*x+c3)

...etc., up to sin8

Y = at*sin(b1*x+c1)+...
+a8*sin(b8*x+c8)

Spline Model Names

Spline models are supported for curve fitting, not for surface fitting.
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Spline Model Names Description

cubicspline

Cubic interpolating spline

smoothingspline

Smoothing spline

Interpolant Model Names

Type Interpolant Model Description
Names
Curves and linearinterp Linear interpolation
Surfaces nearestinterp Nearest neighbor
interpolation
cubicinterp Cubic spline interpolation
Curves only pchipinterp Shape-preserving

piecewise cubic Hermite
(pchip) interpolation

Surfaces only

biharmonicinterp Biharmonic (MATLAB
griddata) interpolation

thinplateinterp Thin-plate spline
interpolation

Lowess Model Names
Lowess models are supported for surface fitting, not for curve fitting.

Lowess Model Names Description

lowess

Local linear regression

loess

Local quadratic regression
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Polynomial Models

In this section...

“About Polynomial Models” on page 4-19

“Fit Polynomial Models Interactively” on page 4-20
“Fit Polynomials Using the Fit Function” on page 4-22
“Polynomial Model Fit Options” on page 4-35

“Defining Polynomial Terms for Polynomial Surface Fits” on page 4-36

About Polynomial Models

Polynomial models for curves are given by

n+l

y = z i xn+1—i
=1

where n + 1 is the order of the polynomial, n is the degree of the polynomial,
and 1 < n <9. The order gives the number of coefficients to be fit, and the
degree gives the highest power of the predictor variable.

In this guide, polynomials are described in terms of their degree. For example,
a third-degree (cubic) polynomial is given by

3 2
Y =D1X" + poX” + p3X+ Py

Polynomials are often used when a simple empirical model is required.

You can use the polynomial model for interpolation or extrapolation, or to
characterize data using a global fit. For example, the temperature-to-voltage
conversion for a Type J thermocouple in the 0 to 760° temperature range is
described by a seventh-degree polynomial.
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Note If you do not require a global parametric fit and want to maximize the
flexibility of the fit, piecewise polynomials might provide the best approach.
Refer to “Nonparametric Fitting” on page 6-2 for more information.

The main advantages of polynomial fits include reasonable flexibility for
data that is not too complicated, and they are linear, which means the fitting
process is simple. The main disadvantage is that high-degree fits can become
unstable. Additionally, polynomials of any degree can provide a good fit
within the data range, but can diverge wildly outside that range. Therefore,
exercise caution when extrapolating with polynomials.

When you fit with high-degree polynomials, the fitting procedure uses the
predictor values as the basis for a matrix with very large values, which can
result in scaling problems. To handle this, you should normalize the data by
centering it at zero mean and scaling it to unit standard deviation. Normalize
data by selecting the Center and scale check box in the Curve Fitting app.

Fit Polynomial Models Interactively

1 Open the Curve Fitting app by entering cftool. Alternatively, click Curve
Fitting on the Apps tab.
2 In the Curve Fitting app, select curve or surface data.

¢ [f you select curve data (X data and Y data, or just Y data against
index), Curve Fitting app creates the default curve fit, Polynomial.

¢ [f you select surface data (X data, Y data, and Z data), Curve Fitting
app creates the default surface fit, Interpolant. Change the model type
from Interpolant to Polynomial.

For curves, the Polynomial model fits a polynomial in x.
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Polynomial *
Degree: |1 >
Robust: | Off -

["] Center and scale

Fit Options...

For surfaces, the Polynomial model fits a polynomial in x and y.

Polynomial -
Degrees: = | 1 * y |1 -
Reobust: Off -

Center and scale

Fit Opticns...

You can specify the following options:

¢ The degree for the x and y inputs:
= For curves, degree of x can be up to 9.
= For surfaces, degree of x and y can be up to 5.

The degree of the polynomial is the maximum of x and y degrees. See
“Defining Polynomial Terms for Polynomial Surface Fits” on page 4-36.

¢ The robust linear least-squares fitting method to use (0ff, LAR, or
Bisquare). For details, see Robust on the fitoptions reference page.

¢ Set bounds or exclude terms by clicking Fit Options. You can exclude
any term by setting its bounds to O.

Look in the Results pane to see the model terms, the values of the
coefficients, and the goodness-of-fit statistics.
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Tip If your input variables have very different scales, select and clear the
Center and scale check box to see the difference in the fit. Messages in the
Results pane prompt you when scaling might improve your fit.

For an example comparing various polynomial fits, see “Compare Fits in
Curve Fitting App” on page 2-22.

Fit Polynomials Using the Fit Function

This example shows how to use the fit function to fit polynomials to data. The
steps fit and plot polynomaial curves and a surface, specify fit options, return
goodness of fit statistics, calculate predictions, and show confidence intervals.

The polynomial library model is an input argument to the fit and fittype
functions. Specify the model type poly followed by the degree in x (up to 9), or
x and y (up to 5). For example, you specify a quadratic curve with 'poly2' ,
or a cubic surface with 'poly33"' .

Create and Plot a Quadratic Polynomial Curve

Load some data and fit a quadratic polynomial. Specify a quadratic, or
second-degree polynomial, with the string 'poly2' .

load census;
fitpoly2=fit(cdate,pop, 'poly2')

% Plot the fit with the plot method.
plot(fitpoly2,cdate,pop)

% Move the legend to the top left corner.
legend('Location', 'NorthWest' );

fitpoly2 =

Linear model Poly2:

fitpoly2(x) = p1*x"2 + p2*x + p3

Coefficients (with 95% confidence bounds):
pl1 = 0.006541 (0.006124, 0.006958)
p2 = -23.51 (-25.09, -21.93)
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p3 = 2.113e+04 (1.964e+04, 2.262e+04)
25':' T T T T
+  data
fitted curve

200 - -
150 -
100 + -
0+ -

|:| | | |

1750 1800 1850 1900 1950 2000

Create a Cubic Curve
Fit a cubic polynomial 'poly3"' .

fitpoly3=fit(cdate,pop, 'poly3"')
plot(fitpoly3,cdate,pop)

Warning: Equation is badly conditioned. Remove repeated data points or try
centering and scaling.
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fitpoly3 =

Linear model Poly3:

fitpoly3(x) = p1*x"3 + p2*x"2 + p3*x + p4

Coefficients (with 95% confidence bounds):
pl = 3.855e-06 (-4.078e-06, 1.179e-05)

p2 = -0.01532 (-0.06031, 0.02967)
p3 = 17.78 (-67.2, 102.8)
p4 = -4852 (-5.834e+04, 4.863e+04)
3':":' T T T T
+  data
fitted curve
280+ -
200 - -
= 180} - _
+*
100 + -
g0+ -
|:| | | |
1750 1800 1850 1900 1950 2000
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Specify Fit Options

The cubic fit warns that the the equation is badly conditioned, so you should
try centering and scaling by specifying the 'Normalize' option. Fit the cubic
polynomial with center and scale and robust fitting options.

Robust 'on' is a shortcut equivalent to 'Bisquare' , the default method for
robust linear least-squares fitting method.

fit3=fit(cdate, pop, 'poly3','Normalize’,'on', 'Robust','on')
plot(fit3,cdate,pop)

fit3 =

Linear model Poly3:
fit3(x) = p1*x*3 + p2*x"2 + p3*x + p4

where x is normalized by mean 1890 and std 62.05
Coefficients (with 95% confidence bounds):

pl = -0.4619 (-1.895, 0.9707)
p2 = 25.01 (23.79, 26.22)
p3 = 77.03 (74.37, 79.7)
p4 = 62.81 (61.26, 64.37)
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25':' T T T T ol
+  data
fitted curve

200

150

T
*
1

100

a0

a
1750 1800 1850 1900 1950 2000

To find out what parameters you can set for the library model 'poly3"' , use
the fitoptions function.

fitoptions poly3

ans =

Normalize: 'off'
Exclude: []
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Weights: []
Method: 'LinearLeastSquares'
Robust: 'Off'

Lower: [1x0 double]
Upper: [1x0 double]

Get Goodness of Fit Statistics

Specify the 'gof' output argument to get the goodness-of-fit statistics for the
cubic polynomial fit.

[fit4, gof]=fit(cdate, pop, 'poly3', 'Normalize','on');
gof
gof =

sse: 149.7687
rsquare: 0.9988

dfe: 17
adjrsquare: 0.9986
rmse: 2.9682

Plot the Residuals to Evaluate the Fit

To plot residuals, specify 'residuals' as the plot type in the plot method.

plot(fit4,cdate, pop, 'residuals');
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E 1 1 1 1
+  data
zero line

*

A 1 1 1 1
1750 1800 1850 1900 1960 2000

Examine a Fit Beyond the Data Range

By default, the fit is plotted over the range of the data. To plot a fit over
a different range, set the x-limits of the axes before plotting the fit. For
example, to see values extrapolated from the fit, set the upper x-limit to 2050.

plot( cdate, pop, '0' );
xlim( [1900, 2050] );
hold on

plot( fit4 );

hold off
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450 T T

fitted curve

400

350

300

= 250

200

150

100

5':' | |
1300 1950 2000 2050

Plot Prediction Bounds

To plot prediction bounds, use 'predobs' or 'predfun' as the plot type.

plot(fit4,cdate,pop, 'predobs')
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300

240

200

150

100

a0

+  data
fitted cumve

--------- prediction bounds I

1 | | |
1800 1850 1900 1950

Plot prediction bounds for the cubic polynomial up to year 2050.

plot( cdate, pop, '0' );
x1lim( [1900, 2050] )
hold on

plot( fit4, 'predobs' );
hold off

2000
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a00 . )

fitted curve
450

--------- prediction bounds

400

3al

300

230

200

150

or

5'] | |
1900 1950 2000 2050

Get Confidence Bounds at New Query Points

Evaluate the fit for some new query points.

cdateFuture = (2000:10:2020)."';
popFuture = fit4( cdateFuture )

popFuture =

276.9632
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305.4420
335.5066

Compute 95% confidence bounds on the prediction for the population in the
future, using the predint method.

ci predint( fit4, cdateFuture, 0.95, 'observation' )

ci =

267.8589 286.0674
294.3070 316.5770
321.5924 349.4208

Plot the predicted future population, with confidence intervals, against the
fit and data.

plot(cdate, pop, '0');

x1im([1900, 2040])

hold on

plot(fit4)

h = errorbar(cdateFuture,popFuture,popFuture-ci(:,1),ci(:,2)-popFuture,’'.")
hold off

legend('cdate v pop', 'poly3', 'prediction', 'Location', 'NorthWest')
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'45':' 1 1 I 1 I 1
2 cdate v pop

400 poly3
+  prediction

3al

300

= 240

200

150

100

5'] | 1 | 1 | 1
1900 1920 15940 1960 1980 2000 2020 2040

Fit and Plot a Polynomial Surface

Load some surface data and fit a fourth-degree polynomial in x and y.
load franke;

fitsurface=fit([x,y],z, 'poly44','Normalize','on')
plot(fitsurface, [x,y],2)

Linear model Poly44:
fitsurface(x,y) = p00 + p10*x + pO1*y + p20*x~2 + pi11*x*y + p02*y~2 +
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+ p21*x*2*y + p12*x*y~2 + p03*y~3 + p40*x"4 + p31*x"3*y
+ p22*x"2*y~2 + p13*x*y~3 + p04*y~4
where x is normalized by mean 1982 and std 868.6
and where y is normalized by mean 0.4972 and std 0.2897
Coefficients (with 95% confidence bounds):

-0.02399

p04

po0 = 0.3471 (0.3033, 0.3909)

p10 = -0.1502 (-0.1935, -0.107)

po1 = -0.4203 (-0.4637, -0.377)

p20 = 0.2165 (0.1514, 0.2815)

p11 = 0.1717 (0.1175, 0.2259)

p02 = 0.03189 (-0.03351, 0.09729)
p30 = 0.02778 (0.00749, 0.04806)
p21 = 0.01501 (-0.002807, 0.03283)
p12 = -0.03659 (-0.05439, -0.01879)
po3 = 0.1184 (0.09812, 0.1387)

pa0 = -0.07661 (- 0. 09984, -0.05338)
p31 = -0.02487 (-0.04512, -0.004624)
p22 =  0.0007464 (-0.01948, 0.02098)
p13 = -0.02962 (-0.04987, -0.009366)

(-0.

0474, -0.0005797)
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Polynomial Model Fit Options

All fitting methods have the default properties Normalize, Exclude, Weights,
and Method. For an example, see “Specifying Fit Options at the Command
Line” on page 4-11.

Polynomial models have the Method property value LinearLeastSquares, and
the additional fit options properties shown in the next table. For details on
all fit options, see the fitoptions reference page.
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Property Description

Robust Specifies the robust linear least-squares fitting method
to use. Values are 'on', 'off', 'LAR', or 'Bisquare"’.
The default is 'off"'.

"LAR' specifies the least absolute residual method and
'Bisquare' specifies the bisquare weights method. 'on'
is equivalent to 'Bisquare’', the default method.

Lower A vector of lower bounds on the coefficients to be fitted.
The default value is an empty vector, indicating that
the fit is unconstrained by lower bounds. If bounds are
specified, the vector length must equal the number of
coefficients. Individual unconstrained lower bounds can
be specified by -Inf.

Upper A vector of upper bounds on the coefficients to be fitted.
The default value is an empty vector, indicating that
the fit is unconstrained by upper bounds. If bounds are
specified, the vector length must equal the number of
coefficients. Individual unconstrained upper bounds can
be specified by Inf.

Defining Polynomial Terms for Polynomial Surface
Fits

You can control the terms to include in the polynomial surface model by
specifying the degrees for the x and y inputs. If i is the degree in x and j is the
degree in y, the total degree of the polynomial is the maximum of i and j. The
degree of x in each term is less than or equal to i, and the degree of y in each
term is less than or equal to j. The maximum for both i and j is five.

For example:

poly21 Z

p00 + p10*x + pO1*y + p20*x"2 + p1i1*x*y

poly13 Z p00 + p10*x + pO1*y + pli1*x*y + p02*y~2

+ p12*x*y~2 + p03*y~3
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See Also

Related
Examples

poly55 Z = p00 + p10*x + pO1*y +...+ pld*x*y~4

+ pO5*y"5

For example, if you specify an x degree of 3 and a y degree of 2, the model
name is poly32. The model terms follow the form in this table.

Degree of Term 1 2

0 y y?

1 Xy Xy?
2 x%y N/A
3 N/A N/A

The total degree of the polynomial cannot exceed the maximum of i and j. In
this example, terms such as x%y and x%y? are excluded because their degrees

sum to more than 3. In both cases, the total degree is 4.

fit | fittype | fitoptions | “Polynomial Model Names and Equations”

on page 4-15

¢ Compare Polynomial Fits Interactively

¢ Compare Polynomial Fits at the Command Line

¢ Polynomial Curve Fitting in MATLAB
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Exponential Models

In this section...

“About Exponential Models” on page 4-38
“Fit Exponential Models Interactively” on page 4-38
“Fit Exponential Models Using the Fit Function” on page 4-40

About Exponential Models

The toolbox provides a one-term and a two-term exponential model as given by

y= aebx

y = aeP +ce

dx

Exponentials are often used when the rate of change of a quantity is
proportional to the initial amount of the quantity. If the coefficient associated
with b and/or d is negative, y represents exponential decay. If the coefficient
is positive, y represents exponential growth.

For example, a single radioactive decay mode of a nuclide is described by a
one-term exponential. a is interpreted as the initial number of nuclei, b is the
decay constant, x is time, and y is the number of remaining nuclei after a
specific amount of time passes. If two decay modes exist, then you must use
the two-term exponential model. For the second decay mode, you add another
exponential term to the model.

Examples of exponential growth include contagious diseases for which a cure

is unavailable, and biological populations whose growth is uninhibited by
predation, environmental factors, and so on.

Fit Exponential Models Interactively

1 Open the Curve Fitting app by entering cftool. Alternatively, click Curve
Fitting on the Apps tab.



Exponential Models

2 In the Curve Fitting app, select curve data (X data and Y data, or just Y
data against index).

Curve Fitting app creates the default curve fit, Polynomial.

3 Change the model type from Polynomial to Exponential.

: Exponential -
Mumber of terms | 1 -
Equaticn: a*explb™x])

Center and scale Fit Options...

You can specify the following options:

® Choose one or two terms to fit exp1 or exp2.

Look in the Results pane to see the model terms, the values of the
coefficients, and the goodness-of-fit statistics.

¢ (Optional) Click Fit Options to specify coefficient starting values and
constraint bounds appropriate for your data, or change algorithm settings.

The toolbox calculates optimized start points for exponential fits, based on
the current data set. You can override the start points and specify your own
values in the Fit Options dialog box.

The fit options for the single-term exponential are shown next. The
coefficient starting values and constraints are for the census data.
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<} Fit Options For expl

ilethod: mHonlinearLeastSguares
Robust |off =1
Algarithim: |Tru5t—Regi|:|n j
DifMinChange: | 1.0E-8
DiffMaxChanoe: | 0.1
MaxFunEvals: | GO0
Maxlter: | 400
TolFun: | 1.0E-6
Tal: | 1.0E-6
Linknowns| StartPoint| Lower Llpper
a 49.04e-15 -] Inf
1] 1.91e-02 -1rf] Inf]
Help

Fitting method and algorithm

Finite differencing parameters

Fit convergence criteria

Coefficient parameters

For an example specifying starting values appropriate to the data, see
“Gaussian Fitting with an Exponential Background” on page 5-38.

For more information on the settings, see “Specifying Fit Options and
Optimized Starting Points” on page 4-7.

Fit Exponential Models Using the Fit Function

This example shows how to use the fit function to fit an exponential model

to data.

The exponential library model is an input argument to the fit and fittype
functions. Specify the model type ’expl’ or ’exp2’.

Fit a Single-Term Exponential Model



Exponential Models

Generate data with an exponential trend and then fit the data using a
single-term exponential. Plot the fit and data.

X = (0:0.2:5)';
y = 2*exp(-0.2*x) + 0.1*randn(size(x));
f = fit(x,y, 'expl')

plot(f,x,y)

General model Expt:

f(x) = a*exp(b*x)

Coefficients (with 95% confidence bounds):
a = 2.021 (1.89, 2.151)
b = -0.1812 (-0.2104, -0.152)
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22 1 1 1 1 1 1 1 1 1
* +  data
fitted cure |

Fit a Two-Term Exponential Model

f2 = fit(x,y, 'exp2')
plot(f2,x,y)

General model Exp2:
f2(x) = a*exp(b*x) + c*exp(d*x)
Coefficients (with 95% confidence bounds):
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a = 9.646e+04 (-1.2e+15, 1.2e+15)
b = -0.2575 (-1.172e+04, 1.172e+04)
c = -9.646e+04 (-1.2e+15, 1.2e+15)
d = -0.2575 (-1.172e+04, 1.172e+04)
22 T T T T T T T T T
+ +  data
2" fitted curve |

Set Start Points
The toolbox calculates optimized start points for exponential fits, based on

the current data set. You can override the start points and specify your
own values.
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Find the order of the entries for coefficients in the first model ('f’) by using the
coeffnames function.

coeffnames(T)
ans =

Ial

Ibl

If you specify start points, choose values appropriate to your data. Set
arbitrary start points for coefficients a and b for example purposes:

f = fit(x,y, ' 'expl', 'StartPoint', [1,2])
plot(f,x,y)

General model Expt:

f(x) = a*exp(b*x)

Coefficients (with 95% confidence bounds):
a = 2.021 (1.89, 2.151)
b = -0.1812 (-0.2104, -0.152)
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22 1 1 1 1 1 1 1 1 1
+ +  data
fitted cure |

Find Exponential Fit Options

Examine the fit options if you want to modify fit options such as coefficient
starting values and constraint bounds appropriate for your data, or change
algorithm settings. For more information on these options, see the table of

properties for NonlinearLeastSquares on the fitoptions reference page.

fitoptions('expl')

ans =
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See Also

Related
Examples

Normalize:
Exclude:
Weights:

Method:
Robust:
StartPoint:
Lower:

Upper:
Algorithm:
DiffMinChange:
DiffMaxChange:
Display:
MaxFunEvals:
MaxIter:
TolFun:

TolX:

‘off!
[]

[]
‘NonlinearLeastSquares'

'Off!

[1x0 double]
[1x0 double]
[1x0 double]
'Trust-Region'
1.0000e-08
0.1000
'Notify'

600

400
1.0000e-06
1.0000e-06

fit | fittype | fitoptions

® “Gaussian Fitting with an Exponential Background” on page 5-38
e “Specifying Fit Options and Optimized Starting Points” on page 4-7
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Fourier Series

In this section...

“About Fourier Series Models” on page 4-47
“Fit Fourier Models Interactively” on page 4-47

“Fit Fourier Models Using the fit Function” on page 4-48

About Fourier Series Models

The Fourier series is a sum of sine and cosine functions that describes a
periodic signal. It is represented in either the trigonometric form or the
exponential form. The toolbox provides this trigonometric Fourier series form

n
y=ag+ 2 a; cos(nwx) + b; sin(nwx)
i=1

where a, models a constant (intercept) term in the data and is associated with
the i = 0 cosine term, w is the fundamental frequency of the signal, n is the
number of terms (harmonics) in the series, and 1 <n < 8.

For more information about the Fourier series, refer to “Fourier Analysis

and Filtering”.

Fit Fourier Models Interactively

1 Open the Curve Fitting app by entering cftool. Alternatively, click Curve
Fitting on the Apps tab.

2 In the Curve Fitting app, select curve data (X data and Y data, or just Y
data against index).

Curve Fitting app creates the default curve fit, Polynomial.

3 Change the model type from Polynomial to Fourier.
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i Fourier D
Mumber of terms: | 1 -
Equaticn: a0 + al*cos(™w) + bl *sin(x*w)

Center and scale Fit Options...

You can specify the following options:

e Choose the number of terms: 1 to 8.

Look in the Results pane to see the model terms, the values of the
coefficients, and the goodness-of-fit statistics.

¢ (Optional) Click Fit Options to specify coefficient starting values and
constraint bounds, or change algorithm settings.

The toolbox calculates optimized start points for Fourier series models,
based on the current data set. You can override the start points and specify
your own values in the Fit Options dialog box.

For more information on the settings, see “Specifying Fit Options and
Optimized Starting Points” on page 4-7.

For an example comparing the library Fourier fit with custom equations, see
“Custom Nonlinear ENSO Data Analysis” on page 5-26.

Fit Fourier Models Using the fit Function

This example shows how to use the fit function to fit a Fourier model to data.

The Fourier library model is an input argument to the fit and fittype
functions. Specify the model type fourier followed by the number of terms,
e.g., 'fourier1' to 'fouriers8' .

This example fits the El Nino—Southern Oscillation (ENSO) data. The ENSO
data consists of monthly averaged atmospheric pressure differences between
Easter Island and Darwin, Australia. This difference drives the trade winds
in the southern hemisphere.
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The ENSO data is clearly periodic, which suggests it can be described by a
Fourier series. Use Fourier series models to look for periodicity.

Fit a Two-Term Fourier Model

Load some data and fit an two-term Fourier model.

load enso;
f = fit(month,pressure, 'fourier2')
plot(f,month,pressure)

General model Fourier2:

f(x) = a0 + at*cos(x*w) + bi1*sin(x*w) +
a2*cos (2*x*w) + b2*sin(2*x*w)

Coefficients (with 95% confidence bounds):

a0 = 10.63 (10.23, 11.03)

al = 2.923 (2.27, 3.576)

b1 = 1.059 (0.01593, 2.101)
a2 = -0.5052 (-1.086, 0.07532)
b2 = 0.2187 (-0.4202, 0.8576)
w = 0.5258 (0.5222, 0.5294)
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The confidence bounds on a2 and b2 cross zero. For linear terms, you 